Aiuto con problema programma seriale tra due arduino

Ciao a tutti ragazzi,
Ho bisogno di qualche aiuto/indizio per un problema di lettura dati da seriale inviato da un arduino Nano ad arduino Mega.
Non riesco a indirizzare la stringa di dati in arrivo.
Praticamente con un arduino leggo la pressione di alcuni tasti, invio il segnale tramite seriale all’altro arduino che legge e attiva dei rele!
E fin qua okay.
Il problema è quando premo un tasto speciale che deve inviare 8 dati.. con arduino so che devo inviare due dati speciali, uno prima e uno dopo la mia stringa costruita da un for.
E qui che mi incasino! Non riesco a ricevere o capire come fare... inoltre è possibile che i dati vengano inviati con qualche errore? Ogni tanto noto che la stringa ricevuta abbia dei errori. Aiutooooo
Grazie a tutti, spero che mi sia fatto capire.

non molto, ti sei fatto capire non molto
allora, vediamo cosa ho capito io
due macchine un nano e un mega
su uno hai dei pulsanti, li leggi, cotruisci una stringa e la mandi in seriale all'altro
l'altro riceve la stringa, la interpreta e attiva/disattiva dei rele
e fin qui va (quasi, ci sono degli errori di trasmissione, ma per ora facciam finta)
sul trasmettitore hai un pulsatnte speciale, che dovrebbe, ma non va, accendere tutti i relè del ricevitore
ok quello che vuoi fare è quasi banale, ma tantè....
ora dovresti fare una bella ricerca qui sul forum, perchè come minimo ne abbiamo parlato una carriola di volte, più non so quante volte prima che mi iscrivessi io, la lingua italiana vorrebbe che dicessi "ne hanno parlato"
fatta la ricerca e non trovando nulla di utile potresti indicare cosa hai trovato nella ricerca, e perchè non ti è risultato utile
da ultimo postare i due programmi e un minimo di schema

magari metti sul il programma,chi puo aiutarti si fara' vivo