Aiuto Simulatore di guida(risolto)

Ciao sono nuovo in questo tipo di cose, mi chiamo Simone. Ho trovato un progetto che mi piace e siccome sono poco competente in materia ho acquistato per errore dell'hardware simile ma non uguale a quello del programma che serve al mio progetto.
Ho trovato in rete un ragazzo che simula la vibrazione nei pedali dei simulatori. Se posso allego il link(scusate qualora fosse vietato)

Nel progetto usano arduino uno originale v3 e Motor/Stepper/Servo/Robot Shield for Arduino I2C v2 Kit w/ PWM Driver TOP.
Io invece ho questi:
Scheda uno compatibile con arduino Atmega328 ch340 e questa scheda per i motori:

Posso farlo funzionare con qualche modifica al programma o devo prendere l'hardware specifico?.
Ho notato che nel mio pc Arduino clone viene riconosciuto come usb serial ch340 e non Arduino Uno.

Vi ringrazio per qualsiasi aiuto anche negativo.

messaggio spostato nel forum italiano. si prega di postare in inglese nei forum generali.

Grazie e scusa sono davvero poco pratico. :sweat_smile:

@Glam78 : buongiorno, essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con molta attenzione tutto il succitato REGOLAMENTO ... Grazie. :slight_smile:

Guglielmo

P.S.: Ti ricordo che, purtroppo, fino a quando non sarà fatta la presentazione nell’apposito thread, nel rispetto del suddetto regolamento nessuno ti risponderà (eventuali risposte verrebbero cancellate), quindi ti consiglio di farla al più presto. :wink:

1 Like

Aggiornamento.
Per adesso sono riuscito a far funzionare tutto .
Ho comprato 1 arduino Uno originale e la scheda Adafruit uguale a quella vista nel tutorial.
La nuova scheda funziona con entrambi gli Arduino dopo aver aggiunto le librerie necessarie.
Sia quello originale sia quello non originale del primo acquisto.
La scheda differente che ho preso la prima volta non fa andare i 2 motori che ho posizionato sui pedali.
Sapete dirmi dove e come correggere le stringhe dello skretch da caricare?
Grazie a tutti

Ciao piacere mio.
Ho fatto.
Buona giornata e grazie

Ragazzi oggi ho trovato del tempo per studiare un po'.
Ho trovato una guida dettagliata per usare il Dk motor shield.
Appena avro' tempo faro' dei test ma la discussione per me e' risolta.
Grazie a chiunque abbia perso eventualmente del tempo a riguardo.
Chiudo