Al lanzar squetch al arduino uno no conecta.

Hola a todos tratando de probar la SIM900 ya conectada al arduino uno trato de lanzar un pequeño programa de prueba de prometec y no consigo que conecte pues me da el siguiente error: qué podrá ser?
Esta es la respuesta con el arduino conectado solo.

Arduino:1.8.12 (Windows Store 1.8.33.0) (Windows 10), Tarjeta:"Arduino Yún"

El Sketch usa 5562 bytes (19%) del espacio de almacenamiento de programa. El máximo es 28672 bytes.
Las variables Globales usan 266 bytes (10%) de la memoria dinámica, dejando 2294 bytes para las variables locales. El máximo es 2560 bytes.
No pude encontrar una placa en el puerto seleccionado. Comprueba que has seleccionado el puerto correcto. Si es correcto, prueba a pulsar el botón de Reset de la placa tras iniciar la subida.

Este informe podría contener más información con
"Mostrar salida detallada durante la compilación"
opción habilitada en Archivo -> Preferencias.
[code]

Por favor lee las Normas del foro y edita tu post usando etiquetas de código para los errores que has posteado.

Conecta el arduino solo y desconecta el SIM900.

Ahora intenta subirle el código al arduino y nos comentas como ta va.

Bien pues el problema parece solucionado con el puerto COM pues me indicaba abajo a la derecha yun cuando en realidad era Uno. Lo he cambiado y compila bien. El tema es que no se comunica con el UNO al mandar el código siguiente al introducir el comando AT debe dar Ok como signo de buena conexión. Y no hace nada. Los cables están bien posicionados y el esquema tal como indico abajo. No sé si tendrían alguna idea...

#include <SoftwareSerial.h>
SoftwareSerial SIM900(7, 8); //Seleccionamos los pines 7 como Rx y 8 como Tx

void setup()
{
 SIM900.begin(19200);
 Serial.begin(19200);
 delay(1000);
}

void loop()
{
 //Envíamos y recibimos datos
 if (Serial.available() > 0)
 SIM900.write(Serial.read());
 if (SIM900.available() > 0)
 Serial.write(SIM900.read());
}

Doy por solucionado el tema.