Alexa can’t find the properties. [solved]

Hi
I’ve written a program that uses a cloud coloured light and uploaded it to a nano 33 Iot. It perfectly connects to the dashboard on the arduino web creator site and I can control it from there but after installing the arduino skill and connecting it to my account, Alexa won’t find the properties as new devices as suggested by the tutorials.
Both Alexa and the nano iot are using the same 2,4 ghz WiFi and everything is updated.
Does anyone know where the problem could be?.
Or does anyone even know whether Alexa is supposed to communicate directly with the board or via the cloud in some way?

I've deleted your other cross-post @SAMJBRO.

Cross-posting is against the rules of the forum. The reason is that duplicate posts can waste the time of the people trying to help. Someone might spend 15 minutes (or more) writing a detailed answer on this topic, without knowing that someone else already did the same in the other topic.

Repeated cross-posting will result in a suspension from the forum.

In the future, please take some time to pick the forum board that best suits the topic of your question and then only post once to that forum board. This is basic forum etiquette, as explained in the sticky "How to use this forum - please read." post you will find at the top of every forum board. It contains a lot of other useful information. Please read it.

Thanks in advance for your cooperation.

Sry I thought I deleted the other one.

In the future, if you need a topic moved to a different board, you can click the "Report to moderator" link at the bottom of the post and ask us to move it.

I think it's probably a good idea to put it here in the IoT Cloud Beta board, as some people who are very knowledgeable on Arduino IoT Cloud follow this board.

Update:

I got it to work: So after readding a different smarthome property it suddenly worked. I then readded all my other smart home properties and they all appeared and were functional.

For others with the same problem i would suggest updating everything, using only smart home properties and some patience i guess..