Alimentation externe Arduino Ethernet

Bonsoir à tous,

Je travaille sur une carte Arduino ethernet pour mon projet, et vient le moment où je dois l'alimenter par une source autre que l'adaptateur qui se branche sur le secteur.

Pour cela j'utilise un bloc de 10 piles LR6, ce qui me donne 15 Volts en sortie.
Ne voulant pas alimenter ma carte avec 15V, j'ai mis un petit potentiomètre entre la carte et le bloc de piles pour abaisser la tension à 9 volts. Mais malheureusement elle ne s'allume pas, et je ne comprends pas pourquoi.

Pourtant je peux régler mon adaptateur secteur avec différentes tensions de sortie 5V, 6V 7.5V, 9V ou 12V et par exemple avec les réglages 7.5 ou 9 la carte s'allume et fonctionne correctement.

Avez-vous une idée pourquoi ça ne fonctionne pas avec le bloc de piles ?

Merci !!!

t'as branché comment (où) tes 10 piles ?
il faut faire très attention car selon l'endroit où tu branches il y a (ou pas) un régulateur, si tu les branches là où ce n'est pas régulé, tu risques de tout griller...

Salut,

Pour faire mon test, j’ai branché le bloc de 10 piles sur une breadboard, puis j’ai mis mon potentiomètre comme il faut et je repars sur la carte avec une prise jack. J’ai testé la sortie du jack j’ai 9V et 115mA.

T'as pas juste inversé les polarités dans ta prise "jack" ?
Je serais curieux de savoir comment t'as obtenu 115mA de consommation sans rien brancher (!?)

L'arduino est sensé pouvoir être alimenté avec une tension entre 7 et 21V en entrée régulée via son connecteur d'alimentation externe (je suppose que c'est ce que t'appelles la prise "jack"). Essaie donc de brancher tes piles sans ce "potentiomètre" pour voir ce qu'il se passe...

Ne faudrait il pas que tu fabriques un pont diviseur de tension (avec 2 resitances) pour abaisser le voltage, à la place d'un simple potar ?

J'ai bien vérifié la polarité par rapport à mon adaptateur le + est à l'intérieur du connecteur et le - en extérieur. Ce que j'appelle le jack c'est la prise ronde que tu mets dans le connecteur noir de la carte.

J'ai viré le potentiomètre et je lui ait balancé les 15V et là ça marche ! Mais je vois pas en quoi le potentiomètre peut gêner...

julien698:
J'ai viré le potentiomètre et je lui ait balancé les 15V et là ça marche ! Mais je vois pas en quoi le potentiomètre peut gêner...

Un potentiomètre n'est pas un régulateur ni un diviseur de tension (U qui se mesure en Volts (V)), c'est seulement une résistance qui limite le courant qui passe (I, qui se mesure en Ampères (A)). Si la résistance de ton potentiomètre était assez élevée il n'y avait tout simplement pas assez de courant pour alimenter ton Arduino... par analogie avec un tuyau d'arrosage, c'est comme si t'avais pincé le tuyau avec ton potentiomètre : il n'y avait presque plus d'eau qui en sortait... :wink:

Enfin, pour réduire la tension, il faut faire ce que conseillait Tarasbulba : un pont diviseur de tension. Mais le problème peut rester le même en fonction des résistances que tu choisis pour le faire.

Par chance la carte de l'arduino contient dans ses circuits un composant qui est un "régulateur de tension", d'un coté tu lui mets n'importe quoi entre 7 et 21V et de l'autre il sort toujours les 5V dont ton arduino a besoin. Pour débuter tu peux t'en tenir à ça, ce qui est déjà pas mal... :wink:

Par contre ce régulateur de tension n'est branché que sur l'entrée d'alimentation externe (donc ta prise "jack"), si tu mets autre chose que 5V sur le port USB ou ailleurs, tu vas faire griller de manière irréversible ton Arduino qui sera bon pour la poubelle...

Bon ça marche avec les 15 Volts sans soucis, pour la suite je pense que je vais me rabattre vers de vrai accus, je pilote deux moteurs et la solution des piles avec un peu discount :confused:

Merci pour vos réponses en tout cas !

Bonjour , sinon mettre 6piles pour 6x1,5v =9v et mettre les 6 autres en parallèle pour plus d’autonomie et d’intensité …

(+) l–[+ -]----[+ -]----[+ -]----[+ -]----[+ -]----[+ -]–l (-)
l–[+ -]----[+ -]----[+ -]----[+ -]----[+ -]----[+ -]–l

:slight_smile:

en effet, ARTNOW a bien raison, si tu peux monter tes piles en parallèle, ton régulateur de tension va moins chauffer et tes piles vont durer plus longtemps !

ARTNOW:
Bonjour , sinon mettre 6piles pour 6x1,5v =9v et mettre les 6 autres en parallèle pour plus d’autonomie et d’intensité ......
(+) l--[+ -]----[+ -]----[+ -]----[+ -]----[+ -]----[+ -]--l (-)
l--[+ -]----[+ -]----[+ -]----[+ -]----[+ -]----[+ -]--l

et je conseillerais de rajouter une diode en série dans les 2 branches pour éviter l'auto-décharge des piles
en plus cela réduirait un peu la tension donc soulagerait un peu le régulateur

rjnc38 : tu la mettrais comment ta(es) diode(s) ? en série entre quoi et quoi ?

comme ceci

super, merci pour l'info ! :slight_smile:

Zorro_X:
super, merci pour l'info ! :slight_smile:

super pas tant que ça
si on alimente un arduino par piles ou batteries, dans la mesure du possible il faut réduire les pertes donc il vaut mieux se passer du régulateur (pures pertes) et alimenter direct en 5v
les solutions évoquées au début du post étaient de véritables erreurs à plusieurs titres ...

por ma part j'ai opté par l'alimentation en 4.5V, pas besoin de régulateur, c'est pour un circuit d'affichage, c'est peut-être limite de faire ainsi pour des circuits de puissance avec moteurs etc...

ça sera meilleur de mettre un régulateur de tension avec deux capacités sur les deux broches E S la masse reliées entre eux et ça fonctionnera à merveille ! je peux te donner les références et le schéma que j’ai fait moi même pour l’Arduino Uno si tu optes pour cette solution

regulateur-de-tension.jpg

julien698:
je pilote deux moteurs et la solution des piles ...

S'il y a des moteurs à alimenter il est préférable d'utiliser le régulateur interne de la carte arduino et d'alimenter les moteur directement sur l'alim principale.
Les moteurs sont de gros générateurs de parasites, en faisant ainsi on protège l'alim du microcontroleur qui doit être propre.

Le régulateur interne de la carte peut réguler a partir de Vin = 7,5V

/************************************************************************************************/
Pour le potentiomètre que tu n'as pas compris.
Je suppose que :
L'alim fait 15 V
La tension demandée fait 5V
Le potentiomètre fait 15 kohms.

Pour avoir 5V tu place le potentiomètre au 1/3 soit 10 kohms en série et 5 kohms qui vont à la masse.

Il existe un théorème pour ce cas de schéma : le théorème de Thévenin.
Ce théorème permet de définir une alim "équivalente" qui serait composée :

  • d'une source de tension parfaite,( la tension étant celle de sortie du potentiomètre)
  • d'une résistance en série égale à la résistante équivalente des deux résistances en parrallèle.

L'alim équivalente c'est :
Une source de tension de 5Volts avec une résistance série de 3,33 kohms ( 5K // 10k ).

Comme une carte arduino consomme environ 50mA sous 5V sa " résistance apparente pour l'alimentation " est égale à 5V/50mA = 100 ohms qui sont négligeables devant 3,3 kohms. Donc la tension sur l'arduino est quasi nulle.

Corollaire :
Quand on utilise un potentiomètre la charge qu'on lui applique doit être au minimum 10 fois supérieure à la résistance totale du potentiomètre.