Alimentation VIN alimentation USB

Bonjour,

Quel est la différence entre une alimentation via l'usb et une alimentation via VIN et GND ? J'utilise l'ethernet shield R3 officiel et lorsque je souhaite acceder a ma page web local alors que je suis en alimentation par Vin et GND avec un régulateur 7812, impossible d'aller sur la page web meme lorsque j'introduis le cable RJ45 aucune led n'est allumé sauf la led on. Alors que quand j'alimente mon arduino par USB, aucun probleme je peux acceder a la page web et toute les leds fonctionnent (LINK 100M RX TX ON)

Comment faire pour que je puisse acceder a ma page web via l'alimentation VIN GND

bonjour tu a testé la "qualité" de ton 12V lorsque tu le connecte sur le UNO ? quelle tension V "en charge" ? parce qu'un UNO et un shield ethernet alimenté avec du 12VCC ça fonctionne tres bien

je part de mon secteur je passe par un transformateur 230/12V ALT je passe ensuite dans un pont de Greatz qui me délivre ce 12V en continue (mesure multimètre = 13,26 V) ensuite je passe dans un 7812CV (multimètre 10V) et j'entre ensuite dans mon VIN.

Je n'ai pas les 12V espérés mais la tension est suffisante pour alimenter mon arduino ainsi que mon shield

Il y a t-il un "gros" condensateur pour filtrer la sortie du pont ? Il est indispensable (plusieurs centaines de µF).

Valeur de tension : Bien différencier la valeur efficace de l'amplitude max et de la valeur de la tension [u]moyenne[/u] redressée - En alternatif 220 V et 12 V sont des valeurs efficaces, pour avoir l'amplitude maximum il faut multiplier par racine(2)-> Vm = Veff*racine(2) - La tension moyenne redressée par le pont est avec un redressement double alternance Vmoy=2*Vm/PI , moins les chutes de tension dans les deux diodes. Mais à ce niveau on obtient des arches comprises entre Vmax et 0. Il faut ajouter le condensateur pour lisser la tension continue autour de la valeur moyenne. Application : Veff = 12 V--> Vmax = 17 V --> Vmoy = (2*17)/PI = 10,8V --> moins 2 Vdiode = 9.2V moyen

Nota : Définition de la "valeur efficace" d'un signal sinusoïdal: La valeur efficace d'une tension sinusoïdale est la valeur équivalente en volt d'une tension continu qui délivrerait la même puissance dans la même résistance.

Bonjour, L'alimentation est mise en cause.. Mais le problème vient peut être de programme ! Il n'y aurait pas une condition bloquante qui "attend" la liaison serie? Genre while(!serial...

j'ai refait mon alimentation composé d'un transfo 12V 0.66 A que je connecte à un régulateur 7812 avec un condo de 1000µF a son entrée et un condensateur de 100µF a sa sortie ensuite j'attaque un deuxième régulateur 7805 avec un condensateur de 470µF a son entrée. J'ai bien mes 5v a la sortie.

MNT problème mes régulateurs chauffe énormement (je me brule en les touchant) pourtant au multimètre je vois un courant consommé de 0.31A or j'ai mis un refroidisseur dessus qui est aussi super brulant --' et je pense pas que cette puissance necessite un TO3 ? qqch de mal fait dans le montage ?

EDIT : J'en ai discuter avec quelqu'un qui m'a dis que cela venais du fait que la tension a la sortie du pont de greatz est de (12*V2)-(2*0.7) =15.5 (multimetre 16.73V) ce qui nous donnerai (16.73-12)*0.31 = 1.33W a dissiper si je ne me trompe pas ce qui n'est pas énorme --' je ne comprend donc pas pourquoi il chauffe autant et donc se met en sécurité.

Salut,
tes calculs et déductions sont corrects, il y a donc un vrai souci qu’il convient de fixer

  • normalement, il faut mettre un 100nF en parallèle avec chaque chimique, un de tes régulateurs est peut-être en oscillation
  • as-tu le même comportement quand la prise usb est débranchée ?
  • as-tu les 5v à la sortie du 7805, avant qu’il ne s’effondre ?
  • y a-t-il autre chose qui chauffe anormalement sur tes cartes ?

trimarco232: - normalement, il faut mettre un 100nF en parallèle avec chaque chimique, un de tes régulateurs est peut-être en oscillation

Mon schéma est le suivant

trimarco232: - as-tu le même comportement quand la prise usb est débranchée ?

Oui tout les test s'effectue USB débranché

trimarco232: - as-tu les 5v à la sortie du 7805, avant qu'il ne s'effondre ?

5,10 V mesuré au voltmètre

trimarco232: - y a-t-il autre chose qui chauffe anormalement sur tes cartes ?

Ma carte dispose d'une RTC d'un HC-06 quelque resistance de pull up et un buzzer rien de puissance donc.

Aujourd'hui en allumant mon projet le 7812 chauffe moins (va savoir pourquoi alors que je n'ai rien changé) tandis que mon 7805 chauffe un peu plus mais ne se met pas en sécurité rien n'a changé pourtant tout fonctionne va savoir pourquoi lol

je ne comprend donc pas pourquoi il chauffe autant

Question : les régulateurs sont dans quel boîtier ? Un TO220 ou un sot223 ne donneront pas le même résultat.

Je ne répond pas sur ton cas qui relève plutôt de la mauvaise manip ou comme cela a été suggéré de l'accrochage. Je donne une réponse globale sur la chauffe des composants et "aîe je me brûle" .

La notion de résistance a été étendue à la thermique on parle de Rth. La loi "d'Ohm" thermique est P = Rth*(T2-T1) Exactement comme pour les hauteurs ou les tensions on ne traite qu'une différence de température entre deux points.

Dans les datasheets on trouve les résistances thermiques : - Rth junction_case : Rth entre la puce et le boîtier - Rth junction_ambiant : Rth entre la puce et l'air ambiant - Rth case_ambiant : Rth entre le boîtier et l'air ambiant Rappel : La Rth dépend énormément du boîtier et du montage de la puce dans le boîtier, il faut systématiquement consulter la datasheet.

Pour les composants en silicium la température max de la puce ne doit pas dépasser 170 °C. Parfois dans le cas de composants complexes le fabricant conseille de ne pas dépasser 150°C voire 120°C mais c'est assez rare.

Attention à [u]Je me brûle :smiling_imp:[/u] Oui il peut arriver qu'un boîtier soit à 100 °C en fonctionnement permanent. Tant que la température de la puce ne dépasse pas 160 °C (il faut toujours garder une marge de sécurité) le composant ne souffre pas.

Bonjour, 310ma consommé pour si peu de composant me parrais problématique. donc voir de ce coté là.

Sur le schéma électrique, il manque un condensateur sur l'entrée et la sortie du régulateur 5v...

Yan_duino.

Merci pour vos réponse

J'ai modifier le schéma pour diminuer la tension d'entrée sur le Vin et ainsi avoir une puissance a dissiper moins importante et ceci, en plus du dissipateur thermique, diminue la température de ce dernier et reste dans l'ordre de l'acceptable