Alternative IDE for YUN

Hi all,

I tried to use eclipse and other ides with Arduino YUN, but nothing. The same IDEs work fine with Uno and Mega.

Has someone successfully tried to use other ides with yun?????

Thanks.

@xproj

I'm using yun intensively with eclipse.
The only thing not working is the serial monitor over wifi.
What problem do you have?
Best regards
Jantje

HI,

the upload doesn't work.

Launching /Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -patmega32u4 -cavr109 -P /dev/tty.usbmodemfa131 -b57600 -D -Uflash:w:/Users/salvo/Documents/Arduino/sketches/workspace/test/Release/test.hex:i
Output:

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
avrdude finished
upload done

Are you sure this is your yun? /dev/tty.usbmodemfa131

I'm sure...

So you have your yun locally attached to a unix system.
Then it is probably a reset issue. Have you tried to reset the leonardo while uploading?
Have you tried to upload with the arduino IDE with /dev/tty.usbmodemfa131

As a side track:
Which version of the plugin are you using?
Which version of arduino IDE are you using?

For your information:
I'm running on linux but I never succeeded in connecting a yun/leonardo to my linus OS. That (and because I think it is much easier) I always work with the yun over wifi.

Best regards
Jantje