Amplificare segnale <1v

Salve

Mi è stato passato un progetto su cui sto lavorando e ho notato che il tipo ha messo un amplificatore operazionale per alzare un pò il segnale da un sensore: il sensore tira fuori meno di 1v.

Sto cercando di fare un pò di debug "teorico" e siccome non sono bravvissimo in elettronica chiedo a voi. Al pin 2 di questo schema ho il segnale del sensore e al pin 1 dovrei avere il segnale amplificato da collegare ad arduino in un ingresso analogico.

  1. sbaglio o lo schema è errato? non è nè invertente nè non-invertente. Erro?
  2. devo usare uno schema invertente o non invertente?
  3. devo mettere delle resistenze a Rin e Rf o no?

vi prego: non sparatemi link a wikipedia o cose del genere (ho seguito anche qualche videolezione su youtube)... già li ho visti e mi è venuto mal di testa.

Grazie

lo schema é errato. Un amplificatore operazionale messo come adattatore di impedenza (guadagno 1) va collegato l' uscita all' entrata negativa e il segnale al entrata positiva.

Ci sono 2 regole pratiche per poter calcolare un circuito con un operazionali: La differenza di tensione tra le due entrate é 0. (in pratica l' offset ma normalmente non si deve considerarlo) e la resistenza delle entrate é infinita(in pratica é molto grande e percui non si deve considerare). Il guadagno é molto alto >100000. percui una differenza di tensione tra le 2 entrate viene amplificata. per arrivare a 5V basta giá una differenza della grandzza meno di 50µV. per fare un amplificatore serve sempre una retroazione negativa.

Nel circuito l' entrata positiva é a massa (0V). Se la tensione dell' entrata negativa é maggiore di 0V l' uscita é quasi a Massa. Se la tensione dell'entrata negativa é minore di 0V (di poco perché senó rompi l'operazionale l' uscita é a quasi +5V (dipende dal tipo di operazionale di quanto l'ucita puó avvicinarsi alla tensione di aliemntazione.

Ciao Uwe

uwefed:
lo schema é errato.

Grazie uwe

Sono stato ore a capire se ero io o lui ad aver disegnato male!

e comunque con un segnale inferiore ad 1 V, se non parli di pochi mV, puoi benissimo adoperare un comune transistor NPN per l'amplificazione

Trisonic:

uwefed: lo schema é errato.

Grazie uwe

Sono stato ore a capire se ero io o lui ad aver disegnato male!

Era LUI.

Potrebbe andare così?

http://img526.imageshack.us/img526/750/final2ye.png

Quel Operazionale fa da comparatore e non amplifica niente. Da un H sopra una certa tensione e un L sotto. se hai una tensione vicino al punto di cambio e una leggero disturbo sopra l' uchita cambia di contuna. é emglio usare un circuito comparatore con isteresi.

Ciao Uwe

uwefed: Quel Operazionale fa da comparatore e non amplifica niente.

Grazie uwe.

Sono un pò confuso, forse non ho esposto bene il mio problema: il segnale che proviene dal sensore (alimentato a 12v) è molto simile ad un rotary encoder, ad ogni giro emette un piccolo segnale minore di un 1v.

Il tipo mi ha detto di disegnare un comparatore proprio in quella configurazione ( http://img526.imageshack.us/img526/750/final2ye.png ), non so il perchè e siccome ho un pochino più di fiducia in "voi" del forum ho voluto esporre il mio problema anche a voi (due opinioni sono meglio di una... in particolar modo se rischio di far danni!).... forse con parole sbagliate chi lo sa!

Dunque, tu dici che devo configurare così: http://img827.imageshack.us/img827/5857/bhgh.png ? giusto?

Grazie

Il tuo schema è voltage follower, ovvero la tensione in uscita è identica a quella in ingresso però ti permette di passare da una condizione di alta impedenza, tipica di molti sensori, ad una condizione di bassa impedenza, ovvero non amplifichi la tensione del sensori, amplifichi la corrente. Nel tuo caso ti serve, come ti ha già detto Uwe, un comparatore con isteresi dove le due soglie devono essere sufficientemente lontane dalla zona di incertezza del segnale, magari se ci dai qualche dettaglio in più, p.e. il datasheet, sul sensore che devi utilizzare è possibile darti uno schema corretto.

astrobeed: magari se ci dai qualche dettaglio in più, p.e. il datasheet, sul sensore che devi utilizzare è possibile darti uno schema corretto.

purtroppo il sensore ci è sconosciuto, sul transistor vi è riportato questo: 11A/114 ma google non ci da molti risultati...

...quindi lo schema finale (ditemi di si!) è questo?: http://img827.imageshack.us/img827/5857/bhgh.png

Trisonic:
…quindi lo schema finale (ditemi di si!) è questo?: http://img827.imageshack.us/img827/5857/bhgh.png

Ti ho ho già detto di no :smiley:
Ma questo segnale <1V è di tipo analogico oppure è digitale, ovvero passa da quasi 0V a quasi 1V senza valori intermedi ?
Nel caso che il segnale sia digitale puoi misurare con un tester quali sono le tensioni dei due stati logici ?

astrobeed:
Ti ho ho già detto di no :smiley:

allora non ho capito niente… ;(

astrobeed:
Ma questo segnale <1V è di tipo analogico oppure è digitale, ovvero passa da quasi 0V a quasi 1V senza valori intermedi ?
Nel caso che il segnale sia digitale puoi misurare con un tester quali sono le tensioni dei due stati logici ?

è analogico (pare)

Se è analogico allora ti serve un vero e proprio amplificatore e non un comparatore, però se non ci dai gli estremi di tensione di questo segnale è difficile darti uno schema definitivo, serve anche sapere quanta banda occupa.

Tris, a volte sei irriconoscibile. Però è chiaro che da un lato ti tieni abbottonato e dall'altro pretendi un aiuto, non esistono queste vie di mezzo, quindi o di decidi di metterti a disposizione e parlare chiaro oppure arrangiati ]:D

Scrivi "ad ogni giro emette un piccolo segnale minore di un 1v."

Domande: per l'intera durata del giro la tensione misurata col tester è 0? cioè hai sempre 0V ed una volta ogni giro hai circa 1V? Questo impulso di circa 1V ha sempre la stessa ampiezza? (p.es. 700mV) Oppure varia, e se varia da cosa dipende? Questo impulso ha sempre la stessa durata o ad ogni giro dura un tempo differente prima di tornare a 0?

e mo', caro mio, o rispondi a tutte le domande come si deve o chiudi il Topic :grin:

[quote author=Michele Menniti link=topic=143336.msg1093992#msg1093992 date=1359454200] Tris, a volte sei irriconoscibile. Però è chiaro che da un lato ti tieni abbottonato e dall'altro pretendi un aiuto, non esistono queste vie di mezzo, quindi o di decidi di metterti a disposizione e parlare chiaro oppure arrangiati ]:D[/quote]

Recentemente, ad ogni cosa che scrivo sul forum, nessuno mi risponde.... quindi scrivo ciò che mi serve... ;( Comunque tutto l'accrocchio è sempre per il raymarine st50, di cui ho già aperto un topic senza nulla di fatto (leggi sopra): http://arduino.cc/forum/index.php?topic=135779.0

Così mi sono messo in contatto con questo spagnolo che mi ha gentilmente passato tutto, MA disegna una cosa, ne scrive un altra e voi me ne dite un altra ancora... ed io non so più che pensare.

Questo è il punto.... PROF!

[quote author=Michele Menniti link=topic=143336.msg1093992#msg1093992 date=1359454200] Scrivi "ad ogni giro emette un piccolo segnale minore di un 1v."

Domande: per l'intera durata del giro la tensione misurata col tester è 0? cioè hai sempre 0V ed una volta ogni giro hai circa 1V? Questo impulso di circa 1V ha sempre la stessa ampiezza? (p.es. 700mV) Oppure varia, e se varia da cosa dipende? Questo impulso ha sempre la stessa durata o ad ogni giro dura un tempo differente prima di tornare a 0?

e mo', caro mio, o rispondi a tutte le domande come si deve o chiudi il Topic :grin: [/quote]

NON l'ho misurato io l'impulso, ma l'ha misurato lo spagnolo con un oscilloscopio... io al massimo ho un tester più cinese di me ;(

Mi era venuto in mente anche a me di misurare l'impulso con il tester, ma pensavo fosse una misurazione fin troppo spartana! Per questo ancora non l'ho fatto.

Prometto che oggi mi metto con il tester e misuro tutto... però mi dareste (per favore e per piacere) una piccola mano a capire come amplificare sto benedetto impulso??

Eventualmente, giusto per generare contenuti (ci tengo sempre a generare contenuti un pò ovunque), questa è la documentazione che ho trovato qui e lì per la rete:

  1. Manuale ufficiale: http://localhostr.com/files/naYjtMG/ST50Wind.pdf
  2. Un tipo che vende i sensori ad hoc su ebay: http://localhostr.com/files/sMRjOYQ/Wind_Sensors.pdf

Il progetto (se funzionerà) sarà open e pubblicato... ma aiutatemi, solo sono un "programmatore" ;(

Trisonic: Comunque tutto l'accrocchio è sempre per il raymarine st50

Magari se dicevi subito che devi leggere un SS94A era meglio :D Dal tuo ST50 hai due distinte uscite, una puramente digitale sotto forma di impulsi che rappresentano la velocità del vento, una sotto forma di due distinte letture analogiche, gli SS94A, che ti dicono la direzione del vento, serve un pochino di trigonometria per combinare i due valori e ottenere l'angolo. Il SS94A è un sensore magnetico di precisione di tipo raziometrico, ovvero il segnale in uscita è direttamente proporzionale alla tensione di alimentazione, come prima cosa devi verificare se l'anemometro è dotato di un suo regolatore di tensione interno altrimenti dovrai provvedere tu ad alimentarlo tramite uno esterno. Adesso non devi fare altro che usare il tuo tester cinese e misurare la tensione massima e minima che ottieni girando lentamente la banderuola per la direzione del vento, una volta che ci fornisci questi dati "magicamente" apparirà lo schema dell'amplificatore che ti serve.

astrobeed:

Trisonic: Comunque tutto l'accrocchio è sempre per il raymarine st50

Magari se dicevi subito che devi leggere un SS94A era meglio :D Dal tuo ST50 hai due distinte uscite, una puramente digitale sotto forma di impulsi che rappresentano la velocità del vento, una sotto forma di due distinte letture analogiche, gli SS94A, che ti dicono la direzione del vento, serve un pochino di trigonometria per combinare i due valori e ottenere l'angolo. Il SS94A è un sensore magnetico di precisione di tipo raziometrico, ovvero il segnale in uscita è direttamente proporzionale alla tensione di alimentazione, come prima cosa devi verificare se l'anemometro è dotato di un suo regolatore di tensione interno altrimenti dovrai provvedere tu ad alimentarlo tramite uno esterno. Adesso non devi fare altro che usare il tuo tester cinese e misurare la tensione massima e minima che ottieni girando lentamente la banderuola per la direzione del vento, una volta che ci fornisci questi dati "magicamente" apparirà lo schema dell'amplificatore che ti serve.

E più o meno questo lo avevo capito, leggendo il blog dello spagnolo e per fortuna ho già tutto il codice. Ma il problema, per ora, non sono gli SS94A. Per quelli dovrei usare un partitore di tensione (così come ho disegnato nei miei schemi), non ci sono regolatori di tensione interni (guarda http://localhostr.com/files/sMRjOYQ/Wind_Sensors.pdf).

Il problema, per ora, è solo nell'anenometro (e non la veletta), che usa un sensore (pare) magnetico 11A/114. Ed è questo sensore che da l'impulso minore di 1v.

AnTrea: Il problema, per ora, è solo nell'anenometro (e non la veletta), che usa un sensore (pare) magnetico 11A/114.

Ti vuoi decidere a fare questa benedetta misura che ti ho chiesto ? Se non lo fai te la scordi una soluzione.

astrobeed: Ti vuoi decidere a fare questa benedetta misura che ti ho chiesto ? Se non lo fai te la scordi una soluzione.

Mi sa che non funziona proprio nulla.

L'anemometro emette 9.35v fissi

Un sensore hall: 9v fissi L'altro: 11.48v fissi

Mi sa che mi è stato prestato proprio perchè non funzinoava nulla... possibile?

Alla faccia dei milliV. :astonished: