An video of (one of) my problems

Here's mine:


  Product ID:      0x6001
  Vendor ID:      0x0403  (Future Technology Devices International Limited)
  Version:      6.00
  Serial Number:      A70076ay
  Speed:      Up to 12 Mb/sec
  Manufacturer:      FTDI
  Location ID:      0x1a200000
  Current Available (mA):      500
  Current Required (mA):      90

Written on my chip: FTDI 0836-B FT232RL

OK, is there any difference on the circuit board?

Mine is exactly identical to:

There couldn't be any huge differences or it wouldn't work with Windows, but maybe this could give a hint as to why it's not working on Mac.

If you pull the 328p off the Duemilanove you are basically left with a FTDI adapter. Once you have removed the 328p, you can do a loopback test by connecting Pin0(RX) and Pin1(TX) and sending data to the serial port. Any data you send should come right back.

My FTDI chip says

FTDI 0836-B FT 232 RL

exacly as clanof's one does. I tried to remove the ATMega chip and loopback the RX and TX. Both LEDs (TX and RX) blink when I send data, but I don't get anything back in the console.


MyFTDI chip says :


Does anyone have any ideas on why I can’t even get my /dev to display


When I plug in the device?

This device works fine on windows and linux boxes, but doesn’t work on any mac machine for me. Whats even weirder is that I got it to work one time on my macbook, but once I rebooted the macbook, it’s never worked again…

Very strange.


  Product ID:      0x6001
  Vendor ID:      0x0403  (Future Technology Devices International Limited)
  Version:      6.00
  Serial Number:      A6008jhm
  Speed:      Up to 12 Mb/sec
  Manufacturer:      FTDI
  Location ID:      0x1d100000
  Current Available (mA):      500
  Current Required (mA):      Unknown (Device has not been configured)

This is what’s in system profiler. The Current Required field must be because I’m not seeing anything in /dev, hence the driver isn’t even loading properly.

This is the error I see from the mac app "Console" when plugging the arduino board into my mac via USB.

Has anyone seen this? Any suggestions on where to go from here in terms of debugging?

7/21/09 1:36:44 PM kernel USBF: 19022.259 IOUSBCompositeDriver[0x9408d80](FT232R USB UART) GetFullConfigDescriptor(0) returned NULL

Have you tried to uninstall (manually remove) and reinstall the FTDI drivers, Stompyj?

Yeah, multiple times on multiple machines. I'm just about to install the drivers on my mac mini (non-intel) and see how those drivers work.


Still no clue... :-/

Did everyone that is having problems buy their boards off eBay instead of one of these guys ?

I have two Duemilanoves that work perfectly with:

  • MacBook Core Duo (32bit Intel) Leopard
  • Mac Mini Core2 Duo (64bit Intel) Leopard
  • iMac G3 DV (32bit PowerPC) Tiger

If you did buy them on eBay, what is the seller’s name?

Mine is this one:

Bought from Electricwatch seller

Same here. electricwatch was the seller of my board too.

well... that can't be a coincidence.

First thing we need to do is to alert the seller that he is selling boards that don't work on OSX with the regular FTDI driver... I'm almost certain he got his hands on a bad batch of FT232RL chips. If he can't rectify the problem then FTDI would probably like to know about this.

If the Arduinos shipped to you guys via China, there is a good chance the chips used to make your Arduinos are counterfeit. I recently got an oscilloscope from China with a Hoitek serial chipset ( ) . The USB Vendor ID in that chipset was stolen from Maxim ( ), but I'm not certain where the chip design is from. Hoitek seems to make knock-offs of some Atmel chips .

Yep... thanks Gabebear! I'll drop him an message... Today I bought a new Arduino from Sparkfun.. let's see if that one works ;)

Sorry guys,

There is a assembly error on my Arduino boards.

To fix the Mac OSx upload problem, please remove the R2 100ohm resistor.

Many thanks to those guys informed me about this problem.

Sorry again.

Here is the photo for R2 100ohm resistor :

[ch21780][ch35442] electricwatch!

Thanks for sorting it out electricwatch. Much appreciated.