Android App not working or am I not working

I got my nano33 IOT working with some simple code on the IOT Cloud website.
I have built a dashboard and can control the built in LED on pin 13.
I m doing so with a Cloudlight variable.

I have the Android App, and my control panel shows there as well, but..
the "time icon?" in the corner of the dashboard control says "unlinked property"
the control does not function.

Thanks in advance.

@blueeyedpop thanks for the report, we'll check that asap, and get back to you.

sort of gave up/// :confused:

Sorry for the delay, we just shipped version 1.0.2, can you try to update the app and check if now the issue is solved?

Hey, @eclipse1985 I'm having the same issue. :frowning:

Works fine for read only variables, but not read/write variables (displays "unlinked" in app).

Android, latest version. etc.

Yes same problem here. Works fine on the web browser (Chrome).

If you havent solved this yet, try deleting the variables and create a new one (different name). Then link the new variable to the widget.

I'm experiencing this today (July 16, 2020), and it's extremely frustrating - especially as I'm experiencing it while trying to record a tutorial video to demo the operation of the Arduino IoT Cloud!

I have the world's simplest demo, an LED connected to a Nano 33 IoT board. On the web dashboard, I can control it perfectly with both a switch and a pushbutton.

But both the switch and pushbutton on the mobile app have the same error described by @blueeyedpop.

I have rebuilt this from scratch two times now, using different variable and dashboard names, and the same results. I have also built it with just the switch and just the pushbutton - same results.

Have restarted my Android phone (Google Pixel 4a) and have even reinstalled the mobile app - still won't work.

Not sure if it's relevant, but I'm on the Maker plan.

Any help would be appreciated. Thank you!

1 Like

Another update - I have installed the mobile app on two Android tablets, same results - none of the widgets work, each with the "unlinked property" error message as described above.

Also, for what it's worth, I have noticed that when I make a change like adding a widget, changing text or deleting a dashboard the change does not show up on the mobile app unless I log out and log back in.

1 Like

Dude I watch you all the time ur awesome :stuck_out_tongue:

Thanks for your help!

Thanks, appreciate it - now if I can get this issue resolved you'll be seeing an Arduino IoT Cloud video shortly!

1 Like

I may have a lead as to how to resolve this.

I just hooked up an ESP32 and built essentially the same thing, with one difference in the programming.

Instead of using the CloudLight data type for the LED state variable, I use a boolean instead. And it works on both the mobile and desktop, concurrently.

Perhaps the mobile app only "understands" basic variable types? CloudLight was suggested when I searched for "light", and it works fine on the web dashboard.


Yes i tried it with an node mcu board after changing it from light to bool it works perfect

Holy cow, it’s actually you! Just wanted to say thanks for all the effort you put into your videos and articles (they have saved me so many times!)

1 Like

DroneBotWorkshop thank u very much i fixed this problem with ur help thank u again

1 Like

Hi everyone, unfortunately this solution didn't work for me. I've a simple project with NodeMCU + a led and everything works great on web dashboard.

I'm using a boolean variable.

When I try to use the same toggle on Android or iOS, it doesn't turns the led on/off.

Any advices?

Android V 1.0.7 (33)
iOS V 1.0.7 (33)

Hello, I have the same problem.
Did you solved it?

Nope. The last version of both apps are not working.

ok, thanks so much I found other app users with the same problem.

I lost a lot of time trying to solve it.

The only good is that is a good therapy against frustration jajaj

sorry by my ingles is not really good


The problem was solved back with the 1.0.2 update. However, a couple of days ago, I started dealing with this issue again. I don't know why, but I only face it on Android devices. EVERYTHING IS WORKING FINE when I'm taking my iPad or my girlfriend's iPhone. Don't you know what could be the issue?! I also tried to launch my new app, and I got a similar issue. I thought it happened because of the app builder that I used. But I was wrong. It was caused by my mistakes while writing the code for this app.