Anfängerfrage: Arduino langsam ?

... yeah top ... genau das ist die Lösung =) ... das Porblem ist nur das ich jetzt rausfinden muss wie ich meinen Internen Bluetooth-Adapter ausstellen kann. Hab am Lappi einen Knopp, aber der stellt alle Funkverbindungen aus... trotzdem vielen dank an alle die mir geholfen haben =)

Manche kannst du im Bios ausstellen, andere haben ne extra bluetooth anwendung dabei, manche haben nen plug-in in der systemsteuerung in dem das geht. Was auf jedenfall klappen sollte ist wohl das Gerät im Geräte-Manager deines PCs auszustellen...

Vielleicht musst du auch nur die Bluetooth-Wan Verbindung brücken, das hat meist schon den gewünschten Effekt.

Vorteil: Braucht man den BT mal, muss man nur temporär die Netzwerkbrücke entfernen und gut ist.

@ Novocain ich hab das im Gerätemanager ausgestellt. Das hat geholfen. @ apogee nur unter Adaptereinstellungen die Bluetoothverbindung zu deaktivieren, hat nicht genützt. trotzdem danke für den Rat.

Ich hatte auch nichts von deaktivieren, sondern einer Netzwerkbrücke über den BT Port geredet.

ja okay aber mein BT ist inter!!! wo soll ich da was reinstecken^^ naja egal… es funktioniert, ich bin glücklich und fertig =) danke nochmals

Eine Netzwerkbrücke ist digital.

Aber dann passts ja :)

Liebe Grüsse

Hallo ans Forum!

Bei mir gibts auch das Problem unter Windows XP: Kompilieren dauert ca. ne Minute, Upload geht dann fix. Habe bereits allerhand deinstalliert - ohne Wirkung.

Jetzt habe ich herausgefunden, dass beim Kompilieren ein Prozess namens "cmdagent" extrem aktiv ist. Sobald ich den einmal mit dem Task-Manager gekillt habe läuft das Kompilieren bis zum nächsten Neustart des PCs super flott in 10 Sekunden! 8-)

Beste Grüße

Hast Du ne Comodo Firewall laufen...?

Das wohl deine Commodo Firewall, wenn ich an mein Problem zurück denke würde ich sagen das es oft auf Sicherheitssoftware zurück geht wenn der das Kompelieren und oder das Senden an den Ardu langsam ist...

Oh super, das isses!

Comodo komplett ausgeschaltet: 5 Sekunden Comodo Firewall an, Defense+ an, Antivirus an: 60 Sekunden Comodo Firewall an, Defense+ an, Antivirus aus: 10 Sekunden Comodo Firewall an, Defense+ aus, Antivirus aus: 5 Sekunden

Wunderbar, jetzt ists noch schneller - Vielen Dank!! :)

Hi,

weiß eigentlich jemand weshalb Arduino mit eingeschaltetem Bluetooth so langsam wird? Ich hab ne Bluetooth Maus & möchte da ungern drauf verzichten...

Gruß

Sebastian

Mhhh da müsste man mal dem Problem näher auf den grund gehen bist du sicher das es nicht an ner sicherheitssoftware liegt ? Welches Betriebssystem ? Welchen Chipsatz (nicht bluetooth!) hast du ? Was für ein Bluetooth modul ? Hersteller vom Laptop bzw Mainboard ?

Ich hab den Rechner grad nicht vor mir. Aber nachdem ich gestern mal dieses Thema komplett durchgelesen hab & mein Bluetooth deaktiviert hatte ging alles deutlich flüssiger. Vor allem wenn ich in Arduino auf "Tools" geklickt habe hat es vorher Ewigkeiten gedauert bis das Menue geladen war. Ich hab ein T42p von IBM.

Mach mal nen thinkvantage udate über den blauen button oben, ich guck nachher mal bei meinem T61 ob es da ebenfalls so bei bluetooth ist... muss nur erstmal zur FH :-(

Werd ich machen. FH ist doch super! :-)

Kommt auf die Vorlesung an :-D

Mhhh also bei mir mit bt an ist das kein Problem dauert genau so lange... bei mir sitzt bt mit auf der wlan karte könnte mir vorstellen das er bei dir per usb angebunden ist und nicht per mini-pci, mal nen anderen usb port ausprobiert ? sonst falls das und thinkvantage nix bringen sollte organisier dir mal neue treiber für BT und dem Chipsatz der von intel kommen sollte...

Hi,

sooooo. Ich hab jetzt mal ein bischen geschaut... Hatte aktuelle Treiber drauf. Allerdings scheint mein Bluetooth tatsächlich über USB zu laufen. Andere Ports zu benutzen hat nix gebracht. Auch nicht die in der Docking Station. Was aber was gebracht hat, war ein Blick in den Gerätemanager. Dort waren zwei COM Ports aufgeführt die über Bluetooth liefen. Nach dem Löschen selbiger klappt das Arduino Tools-Menue sehr zügig auf.

Danke nochmal an dieser Stelle

Sebastian

Hi!!!

Also ich hatte genau das selbe problem! am Standrechner mit Bluetooth USB Dongle sowie am Netbook (Acer Aspire One) braucht die IDE ne knappe Minute zum starten auf meinem großen Notebook (IBM W700) macht Bluetooth keine Probleme....

Ich würde sagen da gehört an der Entwicklungsumgebung was gemacht denn andere software die mit echten/virtuellen Comports arbeitet macht keine Probleme.

lg joe

Die extrem langen Wartezeiten treten nicht nur bei Bluetooth-Ports auf; auch mit anderen (virtuellen) Com-Ports hat Arduino unter Windows offensichtlich große Probleme. Selbst ohne Bluetooth-Ports hat bei mir das Öffnen des Tools-Menu 40 Sekunden gedauert.

Die Lösung gibt es hier: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1237179908/0 Die überarbeitete "rxtxSerial.dll" wirkt Wunder; scheint mit Arduino 017 - 022 zu funktionieren.

Gruß,

Andreas