Anomalía en lcd 16x2

Hola a todos, espero me puedan ayudar con un problema que presenta una pantalla lcd de 16x2. Cuando enciendo el arduino la pantalla funciona bien y después de algunos minutos comienza a fallar mostrando caracteres extraños. Lo curioso es que cuando el arduino esta apagado de un día para otro se recupera el lcd y vuelve a funcionar bien algunos minutos. Les dejo un fragmento del código. Pense que podría ser problema en las conexiones, así que saque todos los cables soldados y los cambie por pines y pasa exactamente lo mismo. https://forum.arduino.cc/index.php?action=dlattach;topic=529180.0;attach=245475

#include <Wire.h>
#include <LCD.h>
#include <LiquidCrystal_I2C.h>
//mjkdz i2c LCD board
//                    addr, en,rw,rs,d4,d5,d6,d7,bl,blpol
LiquidCrystal_I2C lcd(0x3F, 2, 1,0,4,5,6,7,3, POSITIVE);
lcd.begin (16,2);
  lcd.setBacklight(LED_ON);
  lcd.clear();
  lcd.setCursor(0,0);
  lcd.print("Sistema Inflado");

Gracias!
2018-02-14 09.35.20.jpg

Como lo alimentas, que fuente usas, USB o fuente externa?

En este momento eterna de 9V, pero realice la prueba con usb y es lo mismo.

Me esta pasando algo similar, uso un modulo expansor PCF8574 que conecto a un arduino uno r3 Atmega328 Compatible Ch340 a los pines scl y sda que se encuentran a continuación del pin AREF, uso los 5v del arduino para alimentar el modulo (USB), he cargado decenas de librerías, con solo una librería de ejemplo como test he logrado ver caracteres deformes erróneos, alguna idea si es un problema de librerías?, falla de módulo o compatibilidad de hard?.

Saludos y Gracias!