another avrdude: stk500_getsync(): not in sync: resp=0x00 problem

martinez board was working but now i get the avrdude: stk500_getsync(): not in sync: resp=0x00 error
have installed reinstalled deleted uninstalled all drivers etc. it show up in device manager with the right drivers when i plug it in, usb serial port com8
power light is on, red/green leds light when plugged in, red led blinks when trying to upload a sketch
red/green leds flash when moving the board around

have read the hundreds of posts on this error and have tried everything

this the error code i get

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36
Copyright (c) 2000-2005 Brian Dean,
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is “C:\Users\nn\Desktop\martinez\arduino-1.0.5\hardware/tools/avr/etc/avrdude.conf”

Using Port : \.\COM8
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done. Thank you.

this error popped up one time

Error inside Serial.serialEvent() Bad file descriptor in nativeavailable
at Method)
at Method)

According to this:

If you receive errors when compiling and sending the sketch, you have most likely
a) picked the wrong board
b) picked the wrong COM port
c) have a corrupted firmware download (has happened a few times it seems).
d) Arduino says avrdude: stk500_getsync (): not in sync: resp = 0x00
this does not mean that you have broken device. It’s most likely a driver problem with the FTDI device (arduino usb interface) driver.
Windows will per default install the newest driver (2.8.28), which doesnt seem to work for everybody.
The driver needs to be changed manually for both the USB device and the FTDI (can be seen under device properties), the 2.8.24 version can be downloaded here.
Here is an excellent post by jy0933 describing the procedure in minute detail.
Or try using Windows XP if you still have a machine running it.

hmm "not in sync: resp=0x00" seems to be quite the problem with all the posts

thanks for the help, tried every known driver out there, including the 2.8.24, still no luck

tried on another win7 machine, same result. wish i had xp still

device shows up correctly under port 8, drivers show the ones i load, board blinks 3 reds and then nada

board selected is pro atmega328 which is on the martinez

I'm having the same problem. Everything was working at 1.0.3 and then I did the update just to do the update to 1.0.5.

Looks like a classic case of "if its not broken, don't fix it."... but I fixed it for no reason, so now its broken. Didn't need to update for any reason. Regretting it after an hour of messing with drivers, deleting hidden com ports, burning bootloaders, and testing on two different UNO's.

If anyone did anything specific to fix this problem, please share.

Looks like I just fixed my problem, but I have no good explanation.

I took another computer (win 7 64bit OS), which had 1.0.3 and tried to reproduce the problem. At first it looked like it was happening again. But then I uninstalled the Uno device in the device manager (making sure to check the box to delete the driver from the system), installed the new driver from 1.0.5, burned the bootloader with the AVR ISP from 1.0.5, and then plugged it back in and tested the blink example. It worked.

So then I went back to my original machine with the problem (win 7 32bit OS) and repeated the same process as above. This is basically the same thing I tried at least 3 times before, but for seemingly no rhyme or reason, it worked this time.

So, to fix this problem. Spend an hour doing something. Don't get mad. Just turn off the computer. Then come back 2 days later and try the same thing again.

Don't get mad. Just turn off the computer. Then come back 2 days later and try the same thing again.

XD XD XD XD XD This is not magic! I am IT technician.... I know it!

Arduino IDE 1.5.5
Arduino Driver (1/1/2013)

This is odd, I have no problem uploading a sketch to my UNO. However, I'm now getting the
avrdude: stk500_getsync(): not in sync: resp=0x00 error anytime I try to program a chip on a breadboard.

I've tried multiple Uno's and multiple chips that I had programmed before. Is there something about the 1.5.5 IDE that is causing this?