Another COM port / upload issue

So I know there are many topics already addressing uploading and COM port issues. I think this is different.

This has now happened to 3 different UNO boards!

I'm running a program called 'Moppy' which is a MIDI music interface for floppy drives. It involves outputting data from my computer to the arduino via the USB connection at high rate. It may not actually be that 'high' rate in terms of serial data transfer (i have no idea) I'm just pointing out that i'm moving data.

The program works fine and then, with no changes to code, it doesn't.

I'm getting;

avrdude: ser_open(): can't open device "\.\COM8": The system cannot find the file specified.

Yes, I've checked TOOLS>PORT. The Uno shows up in the correct port. In fact I can plug in all three problem boards in and they all show up in the PORT menu.

Yes, I'm uninstalled and reinstalled the drivers.

Yes, I've turned off the other programs that were sending that data out through the same port before trying to upload.

Yes, I've tried uploading BLINK or even a blank sketch.

Yes, the ATMEGA chip will take a program if I install it on another board. It will even run when put back into the defective board.

I'm guessing this is a serial communication issue at the board level.

QUESTION - is there a way to test the part of the board that does the communicating?

Am I overloading the data port thingy (yes, we've reached the limit of my electronic knowledge) and overloading it?

Thanks for any help.


Maybe your program isn't releasing the serial port.

Maybe your program isn't releasing the serial port.

Yes maybe! And thanks to that feed back I remain in exactly the same situation I was in earlier.

Can you suggest a fix?

Does it involve holding the rested button down or pressing at select times while uploading? Because I've tried the suggestions related in other parts of the Forum and that does not work.