Another ESP32 Port Question

Hello All,
I'm stumped by a problem I've never seen before. I bought an ESP32 with an attached TFT display, Hiletgo TTGO LCD

I'm using a Mac with Mojave, which has no no problem whatsoever recognizing the port when the device is plugged in (CP2104).

Other applications I use have no trouble recognizing the port, except the Arduino IDE.

No matter what I do, the Arduino IDE. won't recognize the port. I've tried different cables and hubs, soft and hard booting, no luck. I'm reasonably sure that this is NOT a driver issue because as far as I can tell the Arduino IDE is the only application that doesn't see the port.

Any Suggestions?

Check out Answer #1:

https://stackoverflow.com/questions/61532386/mac-node-serial-port-not-detecting-connected-usb-device

Unfortunately that fix doesn't apply to this situation. I checked, there's no security issue, intervention, or block as described in that thread. I can open the COM port which is instantiated on my Mac using Serial. The COM port appears, and there's no problem opening the port. It's only the Arduino IDE that can't see it.

I had another ESP32 board (a Wroom 32D) with a CP1202 serial USB port, tried that. It's the exact same symptom. Identical. The Mac sees it, other programs can access it, just not the Arduino IDE.

BTW, I'm using the latest Arduino IDE 1.8.16.

I appreciate the try, thank you.

Problem Solved. I was holding back from Upgrading MacOS for quite awhile because of some older programs. That got worked out and I finally upgraded from Mojave to Monterey. That allowed the latest Arduino IDE to recognize the serial port. Maybe something to do with special characters in the device name? All good now.