Another Keypad problem...

Alright, so I've got a keypad. It's laid out a little strange, but it's just a 4 x 4 basic keypad. I tested for continuity and it works great, I just can't get it to interface with the Arduino.

I tried working with the Keypad tutorial, it told me to install the library in a non-existant location. I figured that was a holdover from a previous version of the IDE, so I installed the keypad library in the normal libraries folder (under hardware). I tried changing the pin mapping, I tried restarting the IDE to rebuild the .o file, I tried 10k and 4.7k pullup resistors, as well as direct wiring. Sometimes I can output garbage to the serial port, sometimes it doesn't register at all.

  char key = kpd.get_key();

    if(key != '\0')
    {
        Serial.print(key);
    }

I also tried removing the !, so when it wasn't reading it should have output a stream of \0. Still nothing. I tried both the original pin mappings, and I also tried moving them so they didn't use pins 0 and 1 (because I'm trying to output the key over the serial port). Also tried Serial.print as HEX, DEC, and BYTE.

Any thoughts? Thanks

It sounds like it's the serial comm. thats messed up.

Try to hook a LED up and turn it on / off with the keypresses on the pad, to verify that the pad and connections are ok.