Another stepper question

Hi Folks,

yesterday I opened up a old broken flatbed scanner device, and removed the stepper motor with two ULN2003A "Darlington Arrays". Well, that thing just don't want to work...

I used the stepper knob example and wired everything in correctly. I unfortunately don't know the pinout of the stepper motor, but it has 6 wires, and both red are the center tap's. That's all I know so far.
Well, here's how I wired everything up:

I know it looks a bit like a mess, but its pretty easy: Pin 8 to 11 from the arduino goes into the ULN2003A Pin 1 to 4 input, and Pin 1 to 4 output of the ULN2003A goes to the stepper motor. The Both center tap wires (red) go to +5V from the arduino.

I used the real colored wires from the stepper motor in this schematic. The colors are: red (2x), Black, brown and yellow.

Okay, the result: everytime I start the schematic, the motor just "wiggles" a bit, or moves very slowly, also wiggling in one direction and can be stoped by just touching it very gently. I also tried using +9V from a PSU to power up the stepper motor. It also just wiggles around, but moves "harder", so it can't be stopped so easily. I tried switching the wires going to the stepper motor, but nothing happens. It just wiggles around or it moves while wiggling.

I am confused as hell, because I ripped of this both ULN2003A chips from the PCB of the scanner, and the stepper motor definately was driven by these chips.

I hope someone can help me out, I don't know what to do.

Thanks :slight_smile:

hmmm..not sure why this might be, but the way the motor has been wired might be your issue....

when you power up, can you rotate the stepper by hand?? When you power up, a properly configured driver, will provide voltage and current to the motor, and this will basically "lock it up", as it causes the coils in the motor to activate if you will...

Does your motor lock up when you apply power? if not, the driver/wiring is not done correctly. also, are you using a separate power supply for the driver and the motor, or are you relying on the arduino to supply this (bad idea with steppers....)

Also, you need to know how you can wire it up, and the differences between unipolar and bi-polar.

have a looksy here: Tutorials Archives - StepperWorld especially towards the bottom of the might provide you with the information you need to make it all work....

Thanks for your answer.

As I said, sometimes the motor will be "locked", which means,I can barely move the motor when it's powered up (i need to use force). and sometimes I can move it, but it just wiggles around.

I use a external 9V Power supply, which is also being grounded to the arduino (9V Runs from the PSU to the both center tap wires and the ULN2003A, and Ground is on the ground rail, and also connected to the arduino).

It works with the 5V coming from the arduino itself, but the motor is very weak, but has the same problems as with 9V.

Edit: I don't understand what you want me to do with the link you posted? :o

I don't know how or why, but soddenly the stepper motor just works fine.

I assume it's a broken cable or loose connection of one of the stepper cables.
But thanks anyway!