Another stk500_recv(): programmer is not responding...

Hi,

I'm fairly new to arduino's. Initially everything worked fine but now I got totally stuck with the famous 'programmer not responding' error, but it seems to be different than what is usually reported.

Some details and test steps:

  • Arduino: nano with atmega168. Pro mini with atmega328 gave the same results. Initially it worked and now it won't
  • PC: lenovo t430 with windows 7.
  • used several drivers
  • used several good quality cables
  • resetting the arduino's at several moments during upload
  • com port number is checked and the right number
  • no device errors in device manager
  • I even used a different pc: a dell inspiron with win8 but it didn't work either.
  • I also used brand new pro mini with a brand new FTDI. Still no result.

What makes me think this may be different is this. The horror started when i removed the arduino IDE (1.6.7) by deleting the files and copied them back a few days later. After re-copying the files the IDE works but i get the programmer not responding error. Besides this when I attempt to upload code the leds on the arduino flash. This means there is some sort of communication. But apparently not sufficient.

Does anyone have a clue? I really don't now what's left to try.

I've spent hours and hours on google and on this forum and tried every possible solution I could find. But I don't manage to get it working but I also think that it's not possible that 2 computers, 3 arduino's, 2 FTDI boards, and a bunch of cables are all dead. Is there any way to check the connection other then just watching if any errors occur during upload?

Ok, after spending another evening on the subject I found the issue. And it was incredibly stupid, but I'll post it anyway since I'm convinced I'm not the only one and one day google may come someone to the rescue. At least I was right that it was not a very common kind of problem.

In my mind I switched the chip types between the nano and the pro mini. Which means I was trying to upload both with the wrong processor selected in the IDE...