any #includes crashes J2SE

I recently installed the arduino IDE and downloaded a .cpp and .h file for a MakeItRobot that I got at Radio Shack from online. I am using the IDE from the windows installer from this site on a windows 8 tablet/laptop. I have updated Java to Java 8 Update 40 and I can see the MakeItRobot library in the arduino IDE. I have found out that if I comment out the #includes <MakeItRobot.h> line, then it doesn’t crash, but it does error out on compile check because the class loader isn’t invoked that is referenced later in the .cpp. However, If I uncomment the #includes line, java crashes. I even just added the library to a blank sketch and ran the check and still J2SE crashes. I then tried to add the bridge library to a blank sketch and check the compile and it crashed. I was thinking maybe its the RadioShack library, but no luck there either. Although it ran for longer with the bridge library before crashing than it did with the MakeItRobot library. Any ideas? Anything I should post for more info? Is there a log that is written somewhere when it stops that I can pull up to troubleshoot?

I just tried it with #includes<Servo.h> and it didn’t crash, so its not the #includes itself, but something that some of some #includes are invoking. When you select the Bridge library it adds a bunch of #includes lines. I also tried deleting all of them except the first one, which was #includes<bridge.h>. It still crashed. I’m not sure what the difference is between Servo.h and Bridge.h yet, but Servo doesn’t crash it and Bridge and the MakeItRobot.h #includes do.

I noticed that both Bridge.h and MakeItRobot.h have a #include <Arduino.h> in them but Servo.h doesn’t. when doing a search of my system, I can’t find any file named Arduino.h in it. Maybe it wasn’t included in the windows installer package? Where can I get it, and where should I put it?