Any resolution to serial port problem in Mac OS X (Yosemite)?

I purchased my Genuino Uno starter kit from arduino.cc and installed arduino-1.6.8-macosx.zip to my OS X Yosemite 10.10.5 system.

http://www.arduino.cc/en/guide/macOSX#toc3 says:

"Copy the Arduino application into the Applications folder (or elsewhere on your computer). If you're using an Arduino Uno or Mega 2560, you don't have any drivers to install."

However, I have the exact same problem as this fellow:

There seem to be many such accounts. I have and followed the directions suggested above and also in the following pages:

http://forum.arduino.cc/index.php/topic,27266.0.html

I have tried another USB cable that I use with my external HD so I know it's not just a power cable.

Specifically, I have tried installing the following:

  • FTDIUSBSerialDriver_v2_3.dmg
  • CH341SER_MAC.ZIP
  • CH34x_Install.zip

Also using

$ sudo nvram boot-args="kext-dev-mode=1"

at the terminal and rebooting after the Chinese drivers.

In /Library/Extensions, "FTDIUSBSerialDriver.kext" shows up but not any of the not "osx-ch341.kext" as I would expect (https://www.mac-usb-serial.com/wordpress/support/de-installation/).

In any event, "$ ls /dev/tty*" and "$ ls /dev/wchu" does not list anything like "tty.wchusbserial" or related. "$ ls /dev/cu*" shows: /dev/cu.Bluetooth-Incoming-Port /dev/cu.Bluetooth-Modem

With the Arduino plugged in and the On light green and the L light orange, I go to This Mac -> System Report -> Hardware -> Serial and I do not see anything listed that would indicate the Arduino is connected.

Thanks for any help.

Do you see your hardware under (Apple)->About This Mac->System Report->Hardware->USB? If not, either the USB cable is faulty or the Arduino is faulty. Even without a driver the USB device should be visible.

The CH340 driver is for certain clones that use the CH340 USB-to-Serial chip. A genuine Arduino/Genuino doesn't use that chip.