Anyone using Emacs with the CEDET package for project management?

I like Emacs for text editing and have used it for years. I'm currently using it as an external editor from Arduino projects.

I've installed the CEDET package, which should enable me to manage an Arduino project fully from within Emacs. but am having trouble getting a handle on it. I've had a google, but can't find a tutorial on using EDET with the Arduino.

I've had a tentative play with the EDE tools, but whatever I do I seem to get the error:

"Invalid versions syntax: '0022ubuntu0.1' "

Which appears to refer to the Arduino IDE version number.

Can anyone suggest a tutorial to get me started, or have any other suggestions, please?


Arduino support for CEDET is really new, as in I posted the first stable CEDET release with it included yesterday, so I’ll guess I’m one of a very few people using it at the moment.

I have the Arduino 1.0 package installed for ubuntu, and had work a few shenannagans to make it happen. My version is 1:1.0+dfsg-6.

The basic doc for the arduino support is here:

The error you see is from loading a version number from this file:


and it is expecting something like “1.0”, which is needed so it can create the right kind of Makefile.

I suppose a simple solution would be to edit version.txt to “fix” the version.txt file. Personally, it would be helpful to me if you could join the CEDET mailing list and work through how to get a reliable version number with me there so we can fix this for everyone.


Thanks for the reply, Eric.

I'm try altering the version number as you suggest and see how I get on. I'll have a look at joining the mailing list as well.

The first thing I did was get rid of the IDE completely and just replace it with a Makefile, so I can use the emacs compile command to build. You can find the Makefile I use in the "microcode" subdirectory of the source tarball for my project:

It is obviously highly specific to the install directories I have and the hardware I'm using, but it works for me and does get the annoying IDE out of my way.

I decided to install emacs 24 to try to get the full features of CEDET, and grabbed the snapshot.

It installed fine and initially I was able to compile, upload to the board and display a serial terminal, it worked well and looked like I was in business.

I now find that I can't get the EDE arduino features - upload and serial terminal, and for the life of me can't find out why!

I've tried un-installing and re-installing all the emacs stuff, including renaming the ~/.emacs file and ~/.emacs.d directory, to no effect. I'm now at a loss as to what to try next and would welcome suggestions.