ap ssid change with external rootfs


I have a yun with an external rootfs on a sd card (ExpandingYunDiskSpace) in ap mode. If I change the default ssid (Arduino YUN-xxxxxxxxxx) to, e.g., MyAP (either in webpanel or by editing /etc/config/wireless) I cannot connect to Yun's wifi anymore. I have tested this with different combinations of two yuns and several laptops and phones. But if I boot the yun without the sd overlay, change the ssid there to MyAP as well, and boot the yun again with the sd overlay back in place, the yun's wifi ap works ok and I can connect.

I ran into this problem when I cloned the sd card of my first yun and tried to use it on my second yun. The ssid originally on the second yun was different from the ssid on the cloned sd card. It seems that if I am using an external rootfs on a sd card, and I am using yun in ap mode, the ssids in /etc/config/wireless of the original filesystem and in /etc/config/wireless in the overlaying filesystem have to be identical.

In client mode I can change the target ssid without any problems.

My yuns are running the latest firmware 1.5.3.

Is this normal behaviour?

Ok, I factory resetted my Yun, made an external rootfs on a sd card, and installed some software I need in my project. Now everything works as expected; I can change the ssid and still connect my Yun.