Arch Linux - Arduino Create Installation

Hi. Some days ago, i received Arduino Create Invite. I tried to install it on Arch Linux 64bit. - First problem i got, was missing libappindicator3.so lib. I installed it via AUR (libappindicator-gtk3 64bit ) - When plugin was successfully communicating with Chrome, i tried to program my orginal Leonardo board. I got missing libncurves error. I deleted ~/.arduino-create/avrdude/bin/avrdude , and linked it to my system package(ln -s /usr/bin/avrdude ~/.arduino-create/avrdude/bin/avrdude ) Now, all is working.

Hi,

libappindicator is there if someone uses Gnome usually. We assumed pro linux users are able to figure out dependencies just reading the installer output but we will provide more instructions, thanks.

About libncurses we actually have a solution, it is to have a static version of avrdude to avoid external deps (if we fix it for Arch, which is updated, than it is broken on Ubuntu who uses the old libncurses). The updated version should be online in 1-2 weeks,

Thanks a lot for your help,

Luca