Ardiuno Decimal and version 10 software


I just recently purchased a Arduino Decimal from Spark Fun Electronics. I’m having the problem that I can’t seem to upload anything to the board – as of today. To begin with I’m using windows XP and I’m running as a limited user (don’t know if that matters, tried running as admin didn’t make much diff). When I first got the board I followed all of the instructions for installation and didn’t have much of a problem. The board TX and RX light flash --like they should – and the the “L” led blinks continuously (not sure if it’s supposed to?).

I uploaded a sketch yesterday and I didn’t seem to have a problem, but now when I try to do that the program freezes up and I can’t do anything and in the mean time the board’s ‘L’ led just keeps flashing very rapidly. I believe the sketch that I uploaded was the blink one… but I’m not sure if it even worked because I went to bed before I even saw if it was working – big project for school, don’t ask. :slight_smile:

I’m not certain if I’m doing something incorrectly or if there is something wrong with my board. I’ve read most of the recent comments here and tried everything including making sure that the COM port is correct and such. I don’t know how to proceed and I’m a little confused on what to do. :o


In responce to the questions:

When I first plug the board in the TX and RX flash a couple of times and then the ‘L’ LED blinks continuously.

In windows hardware manager, as per se the troubleshooting guide the serial port shows up as COM4 so I’m sure that I’m selecting the correct port. The software only allows me to select COM3 and COM4. If COM3 is selected it gives me an error, so I’m sure that I’ve been using the correct port.

I don’t know if the baude rate it set correctly or if it matters I believe that the touble shooting guide dictates that 15200 is the correct speed – the default if 9600. (I’m connecting over usb)

I’m still not sure if the problem is my computer, the board, or the USER! :stuck_out_tongue: hehe

Did you select the correct COM port and board type in the menu in the Arduino software before uploading the scetch ?

When you press the upload button in the Arduino environment, do the TX or RX LED blink at all? If you set upload.verbose to true in your Arduino preferences file (you can find the location in the preferences dialog), what output do you get when you try to upload?

Also check the troubleshooting guide. In particular, make sure you don't have any overaggressive firewall applications active. I'd recommend trying this as an Administrative user too, just to make sure that's not the problem.

How do I set upload.verbose to TRUE? I don't see that option under the preferences.

found the setting for setting it to true... but doesn't make a lick of difference because anytime that I try to communicate with the board the software freezes.

Also, whenever I try to do anything with this software it's really slow and I know it's not my computers fault, because the computer is used for tons of other things that I have not problem doing everyday. As an aside would using a virus scanner effect the use of this program? I'm running Avira Anti-virus.

I'm not using ANY firewall software other then the one built into windows.

If possible, I'd try temporarily disabled the firewall and virus software and uploading. Some of those programs block access to serial ports (e.g. the Arduino USB connection).

My current solution has been to use an old labtop that I have kicking around and install windows 2000 pro. service pack 4 It’s a p266 w/ 96mb ram… woot! ;D I would use linux, but I don’t have the time right now to get that working. Already tried on laptop… doesn’t recognize everything… to make a long story short it’s a pain to say the least.

Anyway I still haven’t figured out why it won’t work with my other two machines, but I’ve tried disabling everything, making sure that I don’t have ports used… it just will not comunicate between the board and the trainer/arduino. :’(


I just recently purchased a Arduino Decimal from Spark Fun Electronics. I'm having the problem that I can't seem to upload anything to the board -- as of today. To begin with I'm using windows XP and I'm running as a limited user (don't know if that

I'm in the same boat. I bought an Arduino USB from Sparkfun tooo, I'm having communications problems between the computer and the Arduino board. I'm getting very specific error messages in the IDE (V10) though

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Are you seeing any error messages?

I'm logged in as an Admin, I've installed updated USB drivers, and Device Manager see's "something" out there on the USB line (USB Serial Converter)

But I don't think I see the rx/tx lights flash when I click on the download icon.


I was finally able to get communications between my laptop and the Arduino working. I had to select COM4 in the IDE. COM1 & COM3 are listed as available, but didn't work for some reason.


Just got back from California and my Holiday break so I'm going to try working on the communication problem again. I'll post something tomorrow when I either get it working or smash my computer to bits in fustration.