Ardublock sur Mac

Bonjour à tous, étant nouvel utilisateur Arduino et récemment sur Macbook, je voudrais solliciter votre aide.

J'ai installé Arduino IDE sans aucun soucis puis création de dossiers pour installer Ardublock, toujours pas de problème.

Je crée alors mon premier programme avec mes blocs sous Ardublock et lorsque je clique sur "Téléverser vers l'Arduino", rien n'est envoyé dans le code source d'Arduino IDE et ce message d'erreur apparait en bas, écrit en orange sur fond noir :

Exception in thread "AWT-EventQueue-0" java.lang.NoSuchMethodError: processing.app.Editor.setText(Ljava/lang/String;)V
at com.ardublock.ArduBlockTool.didGenerate(ArduBlockTool.java:72)
at com.ardublock.core.Context.didGenerate(Context.java:271)
at com.ardublock.ui.listener.GenerateCodeButtonListener.actionPerformed(GenerateCodeButtonListener.java:171)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
at java.awt.Component.processMouseEvent(Component.java:6533)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
at java.awt.Component.processEvent(Component.java:6298)
at java.awt.Container.processEvent(Container.java:2236)
at java.awt.Component.dispatchEventImpl(Component.java:4889)
at java.awt.Container.dispatchEventImpl(Container.java:2294)
at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
at java.awt.Container.dispatchEventImpl(Container.java:2280)
at java.awt.Window.dispatchEventImpl(Window.java:2746)
at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
at java.awt.EventQueue$4.run(EventQueue.java:731)
at java.awt.EventQueue$4.run(EventQueue.java:729)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Le problème semble venir du transfert d'Ardublock vers Arduino car Arduino IDE communique très bien avec la carte UNO.

J'ai installé JAVA sur ma machine mais cela n'a rien changé...

Quelqu'un aurait-il une idée pour me dépanner ?

Avec mes remerciements :wink:

bonjour,
version de l’ide?
jètes un oeil ICI
compatible avec ide 1.6xxx

Version 1.6.13...

J'ai un peu de mal à comprendre quand c'est en anglais :-S

J'ai bien compris qu'il y avait un problème depuis la version 1.6.12 mais je n'ai pas compris comment le régler...

Où modifier le code source ? Je ne vois vraiment pas... Merci de votre aide précieuse !

SVP aidez-moi, je ne sais pas du tout comment solutionner ce problème !

Jean1664:
J'ai bien compris qu'il y avait un problème depuis la version 1.6.12 mais je n'ai pas compris comment le régler...

Dans ce cas, Telecharge la version 1.6.5 de l'IDE, c'est la dernière version qui a fait ses preuve.