Arduino-0007 PATH to avr-g++

I installed Arduino-0006 a while ago and just recently installed -0007 to play with the added serial functionality. I keep coming up with the error that my path is not set to find my avr-g++ compiler.

When I installed -0007 on a fresh computer (one w/o -0006 having been installed) I get no such error message. How do I change the path or is there a way to uninstall -0006 to clear all the path variables?

This is all on OS 10.4.8

would greatly appreciate any help :)

In general, I haven't seen conflicts between different versions of Arduino, but anything's possible. Does the Arduino 0006 still work on the computer you're having trouble with? What's the exact error message you get in Arduino 0007? What directories are they in?

Thanks for the response.

I deleted arduino 0006 and reinstalled it. It now gives me the same error message: Could not find the compiler. avr-g++ is missing from your PATH, see readme.txt for help.

I took a look at the readme but could not find specific information about locating the PATH. I took a look in my libraries and tried to set the PATH there, unsuccessfully. I now know that this is a problem with the setup of my own comp. Arduino is in my Applications folder and used to work...

Anyhow, I have it working on a different computer so I really don't need it to work on both it is just very curious and was wondering if anyone else was having the same issues.

Thanks All.

I've had the same problem on SUSE Linux 10.0, as a regular user. Switching to root, I copied the Arduino files (app, examples, libs, etc.) to the /opt/cross/bin directory, where avr-gcc is installed. Ran ./arduino as root, same problem. Also added this directory to path.

Tried copying avr-gcc to arv-g++. Silly, I know. Arduino then finds avr-g++, but now gets this message in the error window "avr-g++: Matrix.cpp: C++ compiler not installed on this system".

Is it actually looking for "avr-g++". I assumed that just meant whatever version of avr-gcc, that you had. Is there a config file that specifies the external compiler, precompiler, etc.?

I'd like to try v.0006, to see if it is a version problem, but can't seem to find the download.

Any thoughts?

Thanks. Rob

You'll need to install avr-g++ (not just avr-gcc). Arduino compiles your sketch as C++.


Thanks for the reply.

I've downloaded a C++ compiler from Now the compiler runs but I get an error saying that the atmega168 isn't a supported architecture.

Is there a consolidated development package, in RPM format anywhere? Something with the C and C++ compiler, linker, etc. all in one package for installation on a Linux machine?