Arduino 0008 suddenly won't launch - WinXP

I'm neck deep into an Arduino project and today for some reason arduino.exe doesn't launch. No error or anything, just brief hourglass then nothing, even after a hard boot. I reinstalled over the old install but no change. Next will uninstall then re-install but could it be something else? I recently installed 2 different USB port sniffers, then uninstalled them, and now my Arduino [FTDI] shows up on COM5 instead of COM4.

(Windows XP)


Hmm.. does it do the same thing if you use the run.bat instead of arduino.exe? What serial devices do you have installed (i.e. what things in the Device Manager are assigned to COM ports)?

Actually I was able to get it going with run.bat.

But I still can't get the arduino communicating with Max...

Where this all became apparent was when I couldn't get the Arduino to talk to Max (after using it for several days straight with no problems) so I decided to re-flash the arduino which led to the discovery that arduino.exe wouldn't launch.

The other things attached to USB port are an iLok key for ProTools, one for Cubase, a wire to my printer and then a USB hub with various wires coming out for cameras, etc.

I haven't even checked ProTools or Cubase yet - I wonder if I screwed up my all my USB settings with those port sniffer installs/uninstalls. This could turn out to be a long night. Any tips on how to reset these all quickly?

nevermind everything mysteriously fixed itself

except the arduino.exe thing

but I can use run.bat I guess

I think this computer's getting flaky

Sometimes it just won't do stuff >:(

Hmm.. these things are pretty mysterious. I know that the library we use in the Arduino software for doing serial communication (RXTX) might do some type of probe of each COM port on your system at certain times (when the Arduino environment starts, and whenever you open the Tools menu). If these things seem really slow, it might be because one of the COM ports on your system represents a device which somehow takes a long time to respond to the probe. We've had a report of someone disabling bluetooth serial devices fixing these delays.

Yeah, I am having very inconsistent results with Arduino and Max. It's very frustrating because it always seems to crap out when I am trying to demo my project. I try leaving it going but this stops after awhile, too. After 1/2 hour of rebooting, plugging and unplugging, restarting Max, etc., I often have to apologize and give up. Then 10 minutes later after my friend has left it works fine. Fortunately I made a video when it worked so people don't think I'm crazy/lying. But it has brought my progress to a grinding halt since I spend most of my time getting it to work, then never know when it will crap out again. It will work fine at night then I get up in the morning and it doesn't work. Should I reinstall Windows?

Max sees the COM port where the Arduino is (most of the time) but sometimes it just doesn't do anything, no TX/RX lights, nothing. Is there a COM port expert out there who can give me some guidance?


Oh, BTW, I still can't launch arduino.exe from the start menu or clicking it directly, I have to use run.bat. I just got a Wiring card - maybe I will start over.

Update: Okay, the Max issue is solved - it had to do with whether I opened the patch from the "Recent" menu or directly - there were two copies and one was in a folder that didn't have the supporting files, so no soap. Hopefully they will make their file management system better someday.

Meanwhile, still can't launch Arduino.exe without run.bat, but for now at least I can move ahead. Whew.