arduino 0021 on ubuntu 10.10

Hi,

I’ve installed arduino 0018 from ubuntu 10.10 package via aptitude. Since it doesn’t support Uno I downloaded 0021 version and just copy the files in the archive over the old ones. Arduino works but I keep gettin the error: “Serial port COM1 not found…” In the Tools menu Serial port option is not enabled.

Anyone knows what seems to be the problem?

Thanks,
Aleksandar

I reckon putting arduino into the Ubuntu repositories caused more problems than it solved, certainly since it hasn't been updated. It isn't that difficult to install from scratch.

Install the pre-requisites - java 6 runtime of some description (ether open or Sun works), gcc-avr and avr-libc from APT or Synaptic.

Then just extract the arduino archive into your home folder. Once you established it runs from 'places' you can add a shortcut to the desktop or panel.

Dunno whats going to happen with a mangled 0018 in the equation though.......

Thanks,

I'll try to do it that way. I will remove the package and install it manually.

Aleksandar

I use version 0021 of the IDE, downloaded from Arduino site, and I don't have any problems. Just a hint: with 0021 IDE the port is recognized as /dev/ttyACM0

Just a hint: with 0021 IDE the port is recognized as /dev/ttyACM0

Assuming you're using one of the new type Arduinos with the AVR 8U2 USB converter. The older type ones with the FTDI are /dev/ttyUSBx .

Ok. Thanks to all of you:) Does IDE automatically poll all ports or I need to attach arduino board before starting the IDE. I'm still waiting for my board to arive so I didn't check this with board attached to USB port :)

It should find the ports itself and appear as an option in the IDE. You can plug the board in after you've started the IDE and it will find the port, it takes a few seconds on mine though.

Thanks. I’ll give it a try.

Aleksandar

I've had nothing but problems with 0021 on Ubuntu 10.04 and 10.10. I use the 0018 that is in the repositories now. I would like to upgrade, but I get an error every time. I can't remember what the error was right now.

Guess I'm going to have to produce a tutorial for the repository generation.....

I had very similar symptoms on Debian squeeze.

This is what I have done to make it work:

edit ~/.arduino/prefernces.txt serial.port=/dev/ttyUSB0

This was not enough, as /dev/ttyUSB0 belongs to group dialout, and my user ´squeeze´ didn´t have access to it. So I had to become root and say adduser squeeze dialout

Now I can select the serial port.

The problem is in the rxtx library that you got in ubuntu. The java library that arduino distributes in 0018 and the library ubuntu distributes doesn't know to look for ttyACM*.

The version in Natty, however, does.

I've asked Ubuntu to update the packages.

The problem was that Uno was released the week before maverick was released, so there was no way to get it into maverick in time. It is in natty and debian squeeze, however.

Feel free to file bug reports with ubuntu and debian for things like that too, they'll be happy to help with those specific questions.

https://bugs.launchpad.net/maverick-backports/+bug/691323 https://bugs.launchpad.net/maverick-backports/+bug/666849

I'm having a very similar problem, except with a Duemilanove instead of an Uno. Did you ever find a solution?

I tried for about 2 hours to get my arduino to work on ubuntu. I gave up and switched to windows.

When someone figures this out could they 1) post the details of how to get the Arduino 0021 working on Ubuntu 10.10 X64.

2) if changes to the S/W or config are required, perhaps someone could put a deb file in the repository ?

I've got the same problems. Frustrating. Just got 2 Nanos. One for me and one for my 14 year old son.

Thanks, Peter Grace

check out http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1293243021

I'm running KUBUNTU 10.10 amd64 (KDE version of UBUNTU). I went to the kubuntu's kpackagekit and downloaded the one file w/o Java (arduino-core 0018) and it launched the arduino ide automatically. tested the "UNO" board successfully. Performed several uploads then closed the ide program, but couldn't figure out how to re-launch it. Finally downloaded the Java front end/ accompanied program from kpackage and couldn't select the correct serial/USB port. Had only one choice. I then tried it on my windows system and it worked fine. What file do I need to launch the arduino-core 0018 and where is it located.

(this linux thing has been a steep learning curve!)

mrtaylor - Thank you! The following link you posted got me up an working with the Arduino UNO board on my "KUBUNTU 10.10" System.

http://www.arduino.cc/playground/Learning/Linux

The instructions above were perfect with the exception of copying the file from root/usr/lib/jbi/librrxtxserial.so

I used Dolphin (equiv explorer) to copy the file over).

I copied the following file

file:///usr/lib/jni/librxtxI2C-2.2pre1.so

per instructions for amd-64 at the website below.

http://www.arduino.cc/playground/Learning/Linux

...now I need to find instructions for making a desktop shortcut to ./arduino ;(

Created shortcut to "Arduino" on desktop by opening "Dolphin" to where my ./arduino executable was located. exe. /home/arduino/arduino-0022/

Then dragged it to desktop.

You are Welcome :)