Arduino 0021 requires a new Java Development  Kit

Hi,
The release Arduino 0021 requires at least Java Development Kit 1,5,0.
Which Java Platform, Standard Edition JDK 6 Update 22 (JDK or JRE ???) that I have to dowload or it’s a other Link ??.
Willy