Arduino 0022 & UNO; a breeze on 10.04 64bit, not on ubuntu 32bit

Hi all,
here is Ottorino and this is my first post to the list.
I decided to write, since after a couple of days, I realized that solving my problem is beyond my kwnoledge.
I'm completely new to Arduino, Linux is my only OS since 5-6 years, and I'm not new to electronics and programming.

The problem is that I'm not able to upload anything to an Arduino uno, since the serial port menu is greyed.
Worst than that, sometimes is grayed sometimes not and I'm not talking about the fact that Arduino is connected.

Also, everything is ALWAYS working fine on my ubuntu desktop (10.04, amd64) while on my laptop (10.04 32 bit) do not work most of the times.

I'm writing this for the records, and also to clear my mind.

What I did on the 64 bit distribution:
At first I did a lazy
sudo apt-get install Arduino
and soon discover that in the repositories only the 0018 version is available and it do not fit the UNO.
I therefore untarred the 0022
under a directory in my home,
then I removed the file
as found somewhere in the net (sorry, I cannot remember where).

NEVER HAD A PROBLEM WITH Arduino UNO, HERE on 64 bit !!!

Always working, uploading, opening serial and so on. Quite strange behaviour for me, since I always had some minor problems with the 64 bit distribution with other software.

A completely different story with my laptop:
At first I messed up a little, trying to install the whole stuff. I the remove all the mess with sudo apt get remove and through synaptic.

Then I did what is written here
Arduino Forum,
but installed these two 32-bit specific packages (one after the other, as specified in the link above).
0022+dfsg-1 : arduino-core : i386 : Natty (11.04) : Ubuntu
0022+dfsg-1 : arduino : i386 : Natty (11.04) : Ubuntu

then I installed

It worked, and I was eventually able to upload sketches to UNO from my laptop too.
I also tried to open up the serial, and it worked too (I'm interested in monitoring a temperature).

It was yesterday: this morning as I turn the laptop on, I immediately realized that the serial port menu was grayed again. I checked all the reasons I'm aware of (I'm still in the dialout group, nothing changes if UNO is connected or not, dmesg and the like.)
UNO is there, but ubuntu refuses to give access to it.

I also tried to link some ttyS* to ACM0 but without success

What else can I do ?


I must report also that arduino software in now very reluctant to start. Furthermore the laptop is now VEEEEERY slow on turning off,: I cannot guarantee that is due to Arduino

What kind of sketch is on your board at the moment? Does it happen to send a lot of serial data without delays between?
I ran into a lot of problems due to that when starting using Arduino on my Ubuntu 32-bit installation. The whole system seemed to lock up and it for sure wasn't possible to upload anything.

I managed to fix my problem by unplugging the board and holding the reset button while replugging it. While still holding the reset button I chose to upload a blank sketch and released the reset button just before the upload started (when the sketch size was reported).

Hi perhof.
thanks for the help.

Yes, the sketch was using the serial

I did what you suggest on my 64 bit box, the only difference being that I was able to upload an empty sketch only after the reset button was released.

And YES !!!!!
connecting the UNO to the 32bit box, I'm back in business !!

Thanks a lot

Nice. Try to always put in at least some delay in your loops, especially when sending serial data.

To prevent locking myself out time after time after doing the same thing I always add delay(3000) as the first line in my setup() function so that I have a few seconds to upload a new sketch or blank sketch before the program starts not matter how messed up the sketch on the board is.

If you update the 8U2 firmware, all the serial problems disappear.

Arduino Forum see post 34.