arduino 0023 + ubuntu 12.04

BUG !!!

After correcting /usr/lib/avr/include/math.h commenting out the round definition, I still get :

avrdude: stk500_recv(): programmer is not responding !!!

Any help ?

Albatros

and I have exactly the same error :

avrdude: stk500_recv(): programmer is not responding

with arduino 1.0

I did an upgrade a week ago and get this error:

avrdude: stk500v2_ReceiveMessage(): timeout

with arduino 1.0

I tested both 0023 and 1.0 on windows xp and that worked! ( my arduino is not broken XD )

So i confirm the bug, on ubuntu 12.04!

It's not a bug.

Does the arduino show up in /dev? With what permissions? Did you follow the instructions?

groups | grep "$(ls -l /dev/ttyACM* | awk '{print $4}')" > /dev/null && echo "Permissions correct"

does that print out "Permissions correct"? What's the output of

ls -l /dev/ttyACM*

and

groups

I have the same problems.
0023 or 1.0

groups | grep “$(ls -l /dev/ttyACM* | awk ‘{print $4}’)” > /dev/null && echo “Permissions correct”
ok

ls -l /dev/ttyACM0
ok

groups → dialout

When I start-up /dev/ttyACM0 is in the menu.
If I want to upload /dev/ttyACM0 is not found…

It must be in 12.04