Arduino 1.5.7 or 1.5.8 on 32bit OS-X Snow Leopard won't compile for Due (ARM)

Computer is iMAC duo core. OS-X 10.6.8 32bit.

Arduino IDE runs good and compiles AVR scripts just fine.

Selecting DUE however, chokes stating..

Cannot run program "/Users/tolson/Desktop/Arduino158.app/Contents/Resources/Java/hardware/tools/gcc-arm-none-eabi-4.8.3-2014q1/bin/arm-none-eabi-g++": error=86, Bad CPU type in executable

So it seems that the gcc ARM compiler is for x86_64 only. Can we have x86 version please.

Thanks tom

Looking at this a little closer, is it really that the ARM (gcc-arm-none-eabi-4.8.3-2014q1) support for iMAC is only for OS-X 10.7.3 +. So it is not Arduino IDE 1.5.x fault.

How many people are stuck with iMACs that can't be upgraded beyond Snow Leopard (10.6.x)?

If this is the case there goes doing any iMAC Arduino development for ARM processors like the Due. Solution... VBOX with Linux or windows VM.