Arduino 1.5/Due usb problems after update

Ubuntu 12.04 x64. Arduino 1.5.2 with an Arduino Due.

I've been using the Native Port for programming and Serial. Everything has been working fine. I did a system update last night and since then it's gone to hell.

Arduino 1.5.2 interface is extremely unresponsive. I'll click on Tools and sometimes wait 30 seconds for it to come up other times it's fine. Uploading sketches works about 30% of the time. Other times it'll hang on Uploading for about 2 minutes and then come back and say No Device found on ttyACM0 even though it shows up under Serial Ports in Arduino. I've tried hitting Erase and Reset and it doesn't seem to make a difference. I've switched USB ports, no change. Tried running with and without sudo.

Was there a Java update recently that might be causing problems?

I'm having the exact same experience, this can't be as intended...would love to know what is causing this. Slow menus, serial port disappears etc...

Working in windows 7

I had to disable bluetooth to get it to work, with bluetooth on I had the same symptons as described here.

May be helps?