Arduino 1.6.4 crashes/closes before it opens

I recently upgraded to the new arduino 1.6.4 on my mac (was an older version -- unsure which one -- for a few years without issue). Now whenever I open 1.6.4 I see the loading screen and when it states "initializing packages" it just closes. No crash report, no indication of something going wrong, just closes. I've tried uninstalling the IDE and reinstalling, but nothing seems to make a difference. If it matters I'm on the latest version of Yosemite. Any help would be much appreciated.

I also am getting this on my XP machine, it was working correctly till i installed a 3rd party in the board manager = http://arduino.esp8266.com/package_esp8266com_index.json

Then i got a message from the boot manager , can’t remeber what it said, but closed the IDE expecting it to clear the fault, but it no longer works. The same as doov gets above.

I see the loading screen and when it states “initializing packages” it just closes. No crash report, no indication of something going wrong, just closes."

So I removed my custom sketchbook folder. I had changed mine to the d: drive.

Then it says couldn’t find my sketchbook folder it then says will change to the default, I press OK, it then stops working after the message disappears.

Regards

Gary

OK.jpg

UPDATE:

I tried running arduino_debug.exe.

This is the output.

C:\Program Files\Arduino>arduino_debug.exe
Loading configuration…
Initializing packages…
java.lang.NullPointerException
at cc.arduino.contributions.packages.ContributedToolReference.resolve(ContributedToolReference.java:43)
at cc.arduino.contributions.packages.ContributedPlatform.resolveToolsDependencies(ContributedPlatform.java:76)
at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(ContributionsIndexer.java:92)
at processing.app.BaseNoGui.initPackages(BaseNoGui.java:600)
at processing.app.Base.(Base.java:271)
at processing.app.Base.guardedMain(Base.java:215)
at processing.app.Base.main(Base.java:128)

C:\Program Files\Arduino>

Hope this helps ?

Regards

Gary

Thank goodness that I’m not the only one experiencing the same problem.

Environment:-
OS: Windows 7 Ultimate
Processor: AMD Athlon Dual Core Processor 4450B @ 2.3GHz
RAM: 3.50 Gb
System: 32-bit

ARDUINO
Version: 1.6.4 - 2015.05.06
Running the debug module results in;-

C:\Program Files\Arduino>arduino_debug
Loading configuration…
Initializing packages…
processing.app.debug.TargetPlatformException: Could not find boards.txt in C:\Users\nick\AppData\Roaming\Arduino15\packages\arduino\hardware\avr\1.6.2. Is it pre-1.5?
at processing.app.debug.LegacyTargetPlatform.(LegacyTargetPlatform.java:67)
at cc.arduino.contributions.packages.ContributedTargetPlatform.(ContributedTargetPlatform.java:43)
at cc.arduino.contributions.packages.ContributionsIndexer.createTargetPackages(ContributionsIndexer.java:307)
at processing.app.BaseNoGui.loadContributedHardware(BaseNoGui.java:777)
at processing.app.BaseNoGui.initPackages(BaseNoGui.java:615)
at processing.app.Base.(Base.java:271)
at processing.app.Base.guardedMain(Base.java:215)
at processing.app.Base.main(Base.java:128)
C:\Program Files\Arduino>

There is an obvious statement "Could not find boards.txt ". Confirmed missing by checking.

  • Why is it missing?
  • Why is it looking in C:\Users\nick\AppData\Roaming\Arduino15packages\arduino\hardware\avr\1.6.2

I have tried installing using both the .msi and the .exe file with the same dramatic results.

The odd this is that I have installed this very same installation module on my lap-top (running Windows 7 Ultimate 32-bit) - it worked just fine.

Regards,
Nick (Australia)

Looking through the forum and someone else has the problem on Windows 8, looks like its effecting various operating systems, something wrong with how it works with java?

http://forum.arduino.cc/index.php?topic=325509.0

Regards

Gary

Hi All,

I have managed to get the IDE running again !

You have to rename or delete the Arduino15 folder (see image attached to this message)

Then restart the Arduino IDE and it will make a new Arduino15 folder :slight_smile:

You will lose the info that you had as your preferences, but at least it will now run.

Please post back here if you have success doing this.

Regards

Gary

Hi all as a workaround for next time (should this happen again) you can delete all ".json" file and "packages" folder only, then restart the IDE

The bug is being tracked at https://github.com/arduino/Arduino/issues/3248

I believe that I recently had this same problem, after upgrading to windows 10. The IDE would startup (I would get the IDE splash screen) and then it would immediately shut down.

The problem was resolved when I ran the program as Administrator. To test this out for yourself, Find the Arduino Program using the File Explorer, right click it and select "Run as Administrator".

If it works then you will know it's just about ownership and who is allowed to run the program.

Hope this helps someone! :)

Hello,
I am new to the Arduino. I installed the Arduino software in January 2016 (unsure as to version, whatever was standard). Everything worked great. It opened, ran, i did the intro with blinking lights. Set it aside for a few months. Then last month, I picked it back up. Tried to open the Arduino IDE. The launcher box would appear, “initializing packages”, then disappear. Poof. I uninstalled the software. Downloaded the newest version 1.6.9. Same issue. So I found this thread. Ran the debugger. Results:
Loading configuration…
Initializing packages…
java.io.FileNotFoundException: C:\Users[myname]\AppData\Local\Arduino15\package_index.json (Access is denied)
at java.io.FileOutputStream.open0(Native method)
at java.io.FileOutputStream.open(FileOutputStream.java:270)
at java.io.FileOutputStream.(FileOutputStream.java:213)
at java.io.FileOutputStream.(FileOutputStream.java:162)
at processing.app.helpers.FileUtils.copyFile(FileUtils.java:46)
at processing.app.BaseNoGui.initPackages(BaseNoGui.java:580)
at processing.app.Base.(Base.java:295)
at processing.app.Base.guardedMain(BSe.java:222)
at processing.app.Base.main(Base.java:135)
After researching and searching, it seems the subfolder Arduino15 is missing from the local directory on my computer at the above specified location. I created the subfolder at the location, and pasted the 3 files from the Arduino subfolder dist (library_index.json, package_index.json, package_index.json.sig).
Same poof.
So then I thought maybe it was an admin issue. I set all accesses to the subfolder to full access, and selected to run Arduino as an admin.
Still same poof.
Tried to run Arduino in compatibility mode for Windows XP SP 3. Poof.
At this point, I am unsure how to troubleshoot.
Any help would be greeeeeeaaaatttlllyyyy appreciated.
Running Windows 7 Home premium 64-bit.

@ Most of the above posters.

Most currently reliable versions are IDE 1.6.5 r5 and 1.6.9

if you use ESP8266 then 1.6.5 r5 but don't forget to update the core files !

Running Win 7 X64 here btw Win 10 users you may face additional issues so search the forum for windows 10

Additionally some people report that running the "unzipped" version and setting up a shortcut often works quite well.

Thank you for the suggestion, Ballscrewbob! I tried the zip of 1.6.9, but same problem. But then I tried the zip for 1.6.5 r5 and it worked!

1.6.5-r5 uses C:\Users[myname]\AppData\Roaming\Arduino15 instead of C:\Users[myname]\AppData\Local\Arduino15 so that may have something to do with the different results.

If you do end up wanting to use a later version than 1.6.5-r5 a workaround you could try is using the IDE in portable mode by creating a folder inside of the Arduino IDE installation folder named portable. The files that would normally be stored at C:\Users[myname]\AppData\Local\Arduino15 will be put in the portable folder instead.

There are occasions where remnants of previous installations can also cause issues.

Before you jump right in it is always advisable to make a copy of your sketches folder first.

Whenever I have to change the IDE or anything associated with it I use REVO uninstaller set for advanced and delete all it finds.

Then I do a registry clean up with WISE registry cleaner again letting it select all.

After that I also check for and delete the user folder (see Perts listings above)

You can also manually delete drivers (windows) by going into device manager with your Arduino plugged in and selecting the correct com port, right click and uninstall. ( remove the arduino during the uninstall !)

A reboot is always useful after these steps.

If you want to be 100% certain you can always do a full registry search for "Arduino" to nail any stray components.

If its for apple or Linux then somebody else will have to step in here.

Thought I would post an update to Pert's suggestion re adding a portable folder. I downloaded the installer for 1.8.0, installed the program same problem as before with IDE startup. BUT added a new folder named it "portable" in the arduino folder and it all runs!! Thanks you peeps

added portable folder its worked thanks a lot #i dont know

This was happening for me for any version after 1.0.5, most recently 1.8.1.

I use Mac and moved my "Arduino" folder out of Documents (the one that has all the sketches). I just moved it to my desktop, and then it worked. It created a new default sketch folder by itself.

Adding the portable-folder worked for me. I am using 1.8.3.0 on a Windows 10 Thanks for the hint! Sometimes it is so easy...

Hey,

I had same problem, that i just try start IDE, it shows "Initialize packages" and it turned off.

I FIND OUT!!!!

that u need to go to [C:\Users\ComputerName\AppData\Local, find Arduino15 folder, delete it and re-install arduino.

if you can't find AppData, just find upper "file,home,share,view", press on view and check on "hidden items" box.

Because old application data of arduino still saved there, even if you re-install arduino.

and it worked form me!

I have the same problem. I deleted Arduino15, tried to reinstall the IDE and it still failed. Reverted to 1.6.9, and the IDE installed OK except for an error message that one file name was incorrect. Otherwise seems to compile scripts OK.

When I tried to delete all IDE code there were two I was unable to delete without SYSTEM privileges. Not sure if these caused my installation problems.

Funny how this happened to many users at the same time.

It's not necessary to delete the entire Arduino15 folder. It's also completely unnecessary to reinstall the Arduino IDE.

These are the instructions to fix the issue:

There was a problem with Arduino's package_index.json file used for Boards Manager that caused the NullPointerException error and prevented the IDE from starting.

Now the package_index.json file has been fixed, but to recover the Arduino IDE to a working condition you must delete the bad package_index.json from your computer as well as the cache folder, then restart the Arduino IDE as usual.

Windows (regular IDE):

remove file C:\Users\YourUsername\AppData\Local\Arduino15\package_index.json remove folder C:\Users\YourUsername\AppData\Local\Arduino15\cache

Windows (Microsoft Store app):

remove file C:\Users\YourUsername\Documents\ArduinoData\package_index.json remove folder C:\Users\YourUsername\Documents\ArduinoData\cache

Mac:

remove file /Users/YourUsername/Library/Arduino15/package_index.json remove folder /Users/YourUsername/Library/Arduino15/cache

Linux:

remove file /home/YourUsername/.arduino15/package_index.json remove folder /home/YourUsername/.arduino15/cache

Arduino IDE in portable mode:

remove file {Arduino IDE installation folder}/portable/package_index.json remove folder {Arduino IDE installation folder}/portable/cache

NOTE: These are in hidden folders. You will need to configure your file browser software to show hidden folders in order to see them.


Please note that the problem that caused the Arduino IDE to break from the bad package index file has already been fixed and will be in the next release of the IDE. That's the reason why the Nightly/Beta Builds are not affected, and also the reason why we did not detect this problem earlier.

Sorry for any inconvenience this has caused!