Arduino 1.8.1 download error http://drazzy.com/package_drazzy.com_index.json,

Hi, when inserting the link http://drazzy.com/package_drazzy.com_index.json, in preferences, boardmanager url's I get a "download error http://drazzy.com/package_drazzy.com_index.json" warning.

This is the preferences, additional board manager url's content:

https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json,
http://drazzy.com/package_drazzy.com_index.json,
http://digistump.com/package_digistump_index.json,
http://arduino.esp8266.com/stable/package_esp8266com_index.json,
https://mcudude.github.io/MicroCore/package_MCUdude_MicroCore_index.json
https://github.com/Optiboot/optiboot/releases/download/v6.2/package_optiboot_optiboot-additional_index.json

In boards manager I do not have the option to install the ATtinyCore by Spence Konde.

On another pc with W7 64b I do not have this problem.

I used not to have any error until a few days ago; and I cannot remember what I could have done that makes this error appear.

Can you access that URL from the computer having that problem? http://drazzy.com/package_drazzy.com_index.json

I just checked and my webserver is up and serving the page without issue for me - so I'm rather mystified.

In the meantime, you can always do a manual install - I only ever touch the board manager installation when I'm testing if it works; otherwise I sync the repo into the (sketchbook)/hardware folder (which may need to be created). Note that you'll get a much spiffier version of the core that way, currently - the core

I have 4 locations with a hardware folder:

c:/Program Files(x86)/Arduino/hardware/arduino/avr/boards.txt (dated 23/02/2017)

c:/Users/MyName/AppData/Local/Arduino15/packages/arduino/hardware/avr/1.6.16/boards.txt (dated 14/02/2017)

c:/Users/MyName/AppData/Local/Arduino15/packages/arduino/hardware/avr/1.6.17/boards.txt (dated 21/12/2017)

Google Drive/documents/Arduino/hardware/ ..but here only some own board definitions and Optiboot boards

ATTinyCore sits in

c:/Users/MyName/AppData/Local/Arduino15/packages/ATTinyCore/hardware/avr/1.1.2/boards.txt (dated 24/10/2016)

In that folder also are:
externalprogrammers.txt
platform.txt
programmers.txt

and some MD-files.

In the one pc with W7 64b I have this update issue, in the other all is ok. And I can access the url from the problematic pc.

Any suggestion how to proceed please?

The hardware folder for manual installation is the one in your sketchbook folder - this is the folder that sketches default to saving in, normally C:/Users/(your username)/Documents/Arduino on windows - this is the same location that you would use to create your own board definitions. If there is no hardware folder there, you need to create it - it is not created automatically by the installer

It's not clear to me whether you've configured your sketchbook folder to be in google drive, or whether you have not created the hardware folder in your sketchbook folder yet.

The sketchbookfolder is in Google Drive and has a hardware folder in it.

I copied the ATTinyCore folder (including boards.txt, platform.txt, ect..) to the Google Drive folder with the hardware in the sketch folder.

As a result I do get all the ATtinyCore boards in the boards manager but I still get the download error for http://drazzy.com/package_drazzy.com_index.json as soon as I open the hardware board library.

In the boards manager I do not see the ATTinyCore from Spence Konde.

Meanwhile I also deleted the complete Arduino software and reinstalled (this time 1.8.2), still the same error, but now with the added line "no protocol:" before the download error warning.

My other two pc's (W8.1 64b and W7 64b) do not have this issue.

Should I also delete the c:/Users/MyName/AppData/Local/Arduino15 folder when I uninstall?

Anything else?

Any help is greatly appreciated!

Partly solved: I did remove Arduino again, and this time also the preferences.txt from c:/Users/MyName/AppData/Local/Arduino15

New preferences.txt, all boards present as well as updates possible.

But I still have a "no protocol:" error.

What is this?

Fully solved: I had double comma's in the Preferences - Additional Board Manager url's (I found this searching for this issue and I had posted exactly the same error last November :grin: