Arduino 1.8.3 + Esp8266 2.6.3 + Win XP SP3 Issue

Good morning all,

after compiling one of example ESP8266 project ( compile ok) i received following message by upload.py

upload.py --chip esp8266 --port COM14 --baud 115200 --before default_reset --after hard_reset write_flash 0x0 C:\DOCUME~1\Maurizio\IMPOST~1\Temp\arduino_build_441136/Blink.ino.bin

pyserial or esptool directories not found next to this upload.py tool.

any ideas how to solve?

Platform is Arduino 1.8.3 + Esp8266 2.6.3 + Win XP SP3 Issue

ciao

cele

Do anybody have a solution to install and compile esp8266 on win XP SP3?

thanks

cele

i got following messages

Arduino:1.8.6 (Windows XP), Scheda:“Generic ESP8266 Module, 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), dtr (aka nodemcu), 26 MHz, 40MHz, DOUT (compatible), 1MB (FS:64KB OTA:~470KB), 2, nonos-sdk 2.2.1+100 (190703), v2 Lower Memory, Disabled, None, Only Sketch, 115200”

Executable segment sizes:

IROM : 227660 - code in flash (default or ICACHE_FLASH_ATTR)

DATA : 1248 ) - initialized variables (global, static) in RAM/HEAP

RODATA : 672 ) / 81920 - constants (global, static) in RAM/HEAP

BSS : 24840 ) - zeroed variables (global, static) in RAM/HEAP

IRAM : 26388 / 32768 - code in IRAM (ICACHE_RAM_ATTR, ISRs…)

File “C:\arduino-1.8.6\hardware\espressif\esp8266/tools/upload.py”, line 65, in
esptool.main(cmdline)
AttributeError: ‘module’ object has no attribute ‘main’
AttributeError: ‘module’ object has no attribute ‘main’