Arduino 1.8.7 not picking up any libraries

Hi guys,

Just trying to code some sketches on the Arduino and I have lots of issues with libraries. I am using a Wemos D1 mini.

I am downloading the .zip libraries and install all of them on the sketchbook folder, not on the program folder…

c:\myUser\Documents\Arduino\libraries\

Running a simple code for a clock on a LED display, I have downloaded the and the . I have the also installed from another library name. All of them on the above folder as the same name shown.

On the code I include those like below, and not of them are recognised by Arduino giving errors of: no such a file or directory or does not contain a type

#include <DS3231.h>
#include <wire.h>
#include <TM1637Display.h>

I have also been working on running a small Oled 0.96" SPI and couldn’t either make it to work.

As you can see, I create the libraries folders with the same names and nothing happens.

Any help would be greatful.

Thanks

Either you dont have the libs or you installed them incorrectly, possible in the wrong location even.

Not quite enough information to be 100% sure

If you changed your sketchbook location thats where most custom libs are held
Normally you would drop them in the SKETCHBOOK folder inside a folder called libraries that resides there.

@ballscrewbob

Is the 3rd party library directory the same for AVR as for Wemos (as OP is using)?

@Serg069

Please post complete error message that you get.

There is usually no need to place the wire library in the directory for 3rd party libraries; I however have no experience with Wemos, so that might be different.

Hi guys, thanks for having a look.

Basically, what I did, was to install the WEMOS D1 MINI library from the manager, this library went into the folder where Arduino is installed.

After that, reading on website, I saw that my libraries would be better to be installed in the sketchbook so decided to download the .zip and do a manual install, placing them on the sketchbook folder;

c:\myUser\Documents\Arduino\libraries\

c:\myUser\Documents\Arduino\libraries\DS3231
c:\myUser\Documents\Arduino\libraries\TM1637\

So now I should be able to manage the libraries and make sure they are all in the sketchbook folder, and if I use the manager, would be in the installation folder.

But this way is not working for me, don’t know what I am doing wrong here as I am following the recommendations…

See below the copy of my errors messages if that helps:

Arduino: 1.8.7 (Windows 10), Board: “LOLIN(WEMOS) D1 R2 & mini, 80 MHz, Flash, 4M (1M SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 921600”

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Pebble\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Pebble\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Pebble\Documents\Arduino\Sketches\libraries -fqbn=esp8266:esp8266:d1_mini:CpuFrequency=80,VTable=flash,FlashSize=4M1M,LwIPVariant=v2mss536,Debug=Disabled,DebugLevel=None____,FlashErase=none,UploadSpeed=921600 -ide-version=10807 -build-path C:\Users\Pebble\AppData\Local\Temp\arduino_build_241453 -warnings=none -build-cache C:\Users\Pebble\AppData\Local\Temp\arduino_cache_998745 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.esptool.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\esptool\0.4.13 -prefs=runtime.tools.esptool-0.4.13.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\esptool\0.4.13 -prefs=runtime.tools.xtensa-lx106-elf-gcc.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2 -prefs=runtime.tools.xtensa-lx106-elf-gcc-1.20.0-26-gb404fb9-2.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2 -prefs=runtime.tools.mkspiffs.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\0.2.0 -prefs=runtime.tools.mkspiffs-0.2.0.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\0.2.0 -verbose C:\Users\Pebble\Documents\Arduino\Sketches\Clock\Clock.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Pebble\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Pebble\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Pebble\Documents\Arduino\Sketches\libraries -fqbn=esp8266:esp8266:d1_mini:CpuFrequency=80,VTable=flash,FlashSize=4M1M,LwIPVariant=v2mss536,Debug=Disabled,DebugLevel=None____,FlashErase=none,UploadSpeed=921600 -ide-version=10807 -build-path C:\Users\Pebble\AppData\Local\Temp\arduino_build_241453 -warnings=none -build-cache C:\Users\Pebble\AppData\Local\Temp\arduino_cache_998745 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.esptool.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\esptool\0.4.13 -prefs=runtime.tools.esptool-0.4.13.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\esptool\0.4.13 -prefs=runtime.tools.xtensa-lx106-elf-gcc.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2 -prefs=runtime.tools.xtensa-lx106-elf-gcc-1.20.0-26-gb404fb9-2.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2 -prefs=runtime.tools.mkspiffs.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\0.2.0 -prefs=runtime.tools.mkspiffs-0.2.0.path=C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\0.2.0 -verbose C:\Users\Pebble\Documents\Arduino\Sketches\Clock\Clock.ino
Using board ‘d1_mini’ from platform in folder: C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2
Using core ‘esp8266’ from platform in folder: C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2
Detecting libraries used…
“C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2/bin/xtensa-lx106-elf-g++” -D__ets__ -DICACHE_FLASH -U__STRICT_ANSI__ “-IC:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2/tools/sdk/include” “-IC:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2/tools/sdk/lwip2/include” “-IC:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2/tools/sdk/libc/xtensa-lx106-elf/include” “-IC:\Users\Pebble\AppData\Local\Temp\arduino_build_241453/core” -c -w -Os -g -mlongcalls -mtext-section-literals -fno-exceptions -fno-rtti -falign-functions=4 -std=c++11 -ffunction-sections -fdata-sections -w -x c++ -E -CC -DF_CPU=80000000L -DLWIP_OPEN_SRC -DTCP_MSS=536 -DARDUINO=10807 -DARDUINO_ESP8266_WEMOS_D1MINI -DARDUINO_ARCH_ESP8266 “-DARDUINO_BOARD=“ESP8266_WEMOS_D1MINI”” -DESP8266 “-IC:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2\cores\esp8266” “-IC:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2\variants\d1_mini” “C:\Users\Pebble\AppData\Local\Temp\arduino_build_241453\sketch\Clock.ino.cpp” -o nul
Clock:2:20: error: DS3231.h: No such file or directory

#include <DS3231.h>

^

compilation terminated.

exit status 1
DS3231.h: No such file or directory

You need to install the libraries to the libaries subfolder of your sketchbook folder. You can find the location of the sketchbook folder at File > Preferences > Sketchbook location. From the output you provided, I can see that your sketchbook folder is C:\Users\Pebble\Documents\Arduino\Sketches, not c:\myUser\Documents\Arduino as you thought. So of course the Arduino IDE will not find the libraries you installed to c:\myUser\Documents\Arduino\libraries. It's best to use the Arduino IDE's Sketch > Include Library > Add .ZIP library feature to install libraries as this will ensure they are correctly installed.

Thanks Pert, this was the abbreviation of the folder on my first post that I used to explain the problem but the real folder path is that, so

C:\Users\Pebble\Documents\Arduino\Sketches == c:\myUser\Documents\Arduino\libraries\

The Sketches folder is a folder that created to save my projects. The system creates the libraries folder on the Arduino path where my sketches where saved originally and decided to move to that subfolder.

Will try to move the libraries inside the Sketches folder? Would that help?

Thanks,

Right, so I placed the libraries folder inside of where I subcreatd my sketchbook folder and looks it picking up some now the libraries…

So I have now the below folder:

C:\Users\Pebble\Documents\Arduino\Sketches\libraries

But the library is not picking up now. Don’t know where to find this library now, I thought it was inside of the Adafruit library? Do I need to take it out?

Thanks,

Because it's architecture-specific, the Wire library is bundled with the hardware package of the board you are compiling for. The location will depend on which board you have selected from the Tools > Board library. In this case it will be at C:\Users\Pebble\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2\libraries\Wire. But you don't need to worry about that. What you do need to worry about is getting the case of the filename correct. It's Wire.h, not wire.h.

Thanks Pert!!! Getting into the grips of Arduino…

Have a nice wknd