Arduino 101 : Cannot open DFU device 8087:0aba

I recently purchased the Arduino 101 board, and have successfully installed the Arduino IDE (v1.6.7), but am having issues uploading any sketches. When I attempt to upload the Blink sketch, I get the following error:
Sketch uses 29,989 bytes (15%) of program storage space. Maximum is 196,608 bytes.
starting download script
Args to shell: C:\Users\Dad\AppData\Local\Arduino15\packages\Intel\tools\sketchUploader\1.6.4+1.14/x86/bin C:\Users\Dad\AppData\Local\Temp\build9c9ef3bdfe2fccb480bc6e4bac749e41.tmp/Blink.ino.elf COM3 quiet
Serial Port PORT
BIN FILE C:\Users\Dad\AppData\Local\Temp\build9c9ef3bdfe2fccb480bc6e4bac749e41.tmp/Blink.ino.bin
Waiting for device...
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
ERROR: Timed out waiting for Arduino 101.

I have searched a bit online for others having similar issues, and that got me pointed in the direction of the USB drivers. I have tried this on two PC's (Win 10, Win 7, both with only USB2), with the same result. I have also tried two different Arduino 101 boards, same result. As some of the posts suggest, I have tried using the master reset on the Arduino 101 at various times before, during and after the upload, but without success.

I do get a USB disconnect "bong" when I press the master reset, and a USB connect "bong" ~5 seconds later. Attempting to upload a sketch also results in the disconnect/connect events, separated again by ~5 sec. This leads me to believe that there is basic communication between the IDE and Arduino 101, but there are issues with the DFU mode of communication. I do see the "Ports (COM & LPT) / Arduino 101 Serial Monitor (COMx)" device in Device Manager, but have noticed that there is no "libusb (WinUSB) devices / Arduino 101 DFU Interface" in Device Manager in that 5 seconds when the DFU interface should be active. That leads me to think there may be an issue with the USB driver for the libusb/DFU interface.

Has anyone else seen these issues? I am anxious to get on to playing with the IMU on the Arduino 101, but can't seem get out of the gate ...

I just received my 101 last night and am having the same issue and same error messages. Windows 7 and the latest Arduino IDE build.

When I go into the device manager for the USB port it can detect that it is an Arduino 101 but says that it is unable to find drivers for it.

Reading through the posts, it appears as though you can only upload sketches to the Arduino 101 on USB3 :frowning: I ordered and installed a PCI-E USB3 adapter card in my computer, and am able to upload the BLINK sketch successfully now.

For reference, here is the link to Amazon for the USB3 adapter I used, there are a number of them available though : http://www.amazon.com/gp/product/B00DSXG4YW?psc=1&redirect=true&ref_=oh_aui_detailpage_o00_s00

Hopefully a USB2 solution is soon forthcoming.

I have tried both my USB 3 ports as well as both my USB 2 ports.

Update:

I "Removed" the Intel Curie Boards library and then re-installed it and confirmed that I am using a USB 3.0 port.

It seems to have fixed the issue I was having as I have successfully uploaded "Blink".

I am running Windows 7, 64 Bit and IDE 1.6.7.