Arduino 101 driver not found

Hi I am completely new to arduino and I just got the 101. I have downloaded the IDE but it does not recognize the board when I plug it in. I went to the device manager already and tried to update the driver software but when i browse my computer for the driver file and click next it still says unable to install.

Is there a fix for this?? I am on windows 7 and can't seem to find any solutions that work.

I had same problem with WIN XP SP3. Anyone knows? What Intel can support this?

Hi all,
It seems I am not alone in having troubles in making the 101 work. I am trying to connect the 101 with my Windows10 laptop after loading the Intel Curie libraries via Boardmanager. The Arduino/Genuino 101 board is recognised and part of the boards-list when I run the 1.6.8 IDE.

Running the LED-blink sketch resulted in an error message because COM port 4 was used.
Now I run in trouble because the COM port is grayed out in the 1.6.8 IDE, and also Windows10 is not helpful in listing the COM ports.

Any help is appreciated,

John

Edited later. Luckily the troubles I had with the 101 can be explained by the laptop I tried it on. On a desktop there is no issue at all. Sorry for any confusion.
John

Hi. I would make sure you have the latest Arduino 101 package (1.0.5) installed from Board Manager.

The driver files are in %localappdata%\Arduino15\packages\Intel\tools\arduino101load\1.6.4+1.18\drivers

Does Windows Device Manager show the board port?

  • Ports (COM & LPT)

  • Arduino 101 Serial Monitor (COMxx)

Brian

Hi, Brian,
In my case, I did install the core (tried 1.05 and 1.04), and there does exist a com port under device manager named Arduino 101 USB Composite Device (Com3), but

  1. there are two Arduino 101 devices unrecognized shown in the device manager and marked yellow, I cannot find a driver for them on the installed Arduino program folders (neither by searching from internet)
  2. the IDE only displays a COM1 for me to select from, which does not match the COM3 port number shown in teh device manager

I use 1.6.8 IDE, and tried both 1.05 an d 1.04 versions of core. I could not get it work.

Also, you gave a driver location path, but I could not find a path like that on my hard disk, was it under the C:\Program Files\Arduino or it is under an unziped installation package?

Please help, many thanks!

Xin

This won't help with Windows, but I can tell you Arduino 101 has been working great for me with Ubuntu 14.04. Works fine with whatever drivers are in the stock Linux kernel.

I did have to add this in my udev rules folder, so non-root users have permission to access.

# Arduino 101 (Intel Curie)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="8087", ATTRS{idProduct}=="0aba", MODE:="0666"
KERNEL=="ttyACM*", ATTRS{idVendor}=="8087", ATTRS{idProduct}=="0ab6", MODE:="0666"
ATTRS{idVendor}=="8087", ATTRS{idProduct}=="0ab6", ENV{ID_MM_DEVICE_IGNORE}="1"

a work around for WIN XP SP3 at http://forum.arduino.cc/index.php?topic=387662.0

I too had an issue where I couldn't connect to my Arduino 101 (using both a Mac and a Windows 10 laptop).

My solution - PUSH THE USB PLUG FIRMLY INTO THE BOARD CONNECTOR!

The Arduino 101 WILL power up with the connector in at its 1st detent - but it still needs to pushed in further.

I'm not used to having to apply so much force to a USB connector, but there you go - after 3 hours and multiple installs of the Arduino IDE... :o

Here's a twist to all this: I had same issue on Windows 8.1 when I installed the Arduino v1.8.0 IDE and in the Board Manager the "Intel Curie Boards by Intel v1.0.7". The device showed in the "Other" category in the device manager with no drivers installed.

When I changed the Board Manager to point to "Intel Curie Boards by Intel v1.0.6" a driver did get installed and shows up as COM3 in the IDE and the device manager does show Arduino 101 as COM3.

And, finally, changing back to the v1.0.7 the device still shows up as COM3. So I'm thinking the driver is not getting installed with v1.0.7, but is retained from v1.0.6.

Who owns the board package for "Intel Curie Boards by Intel v1.0.7"? They've got some splaining to do!

1.0.7 here under win 7 x64 with IDE 1.8.0

Win 8.0 / 8.1 has KNOWN driver issues.
Maybe turn OFF driver enforcement to start.

Win 7 to 10 also has some antivirus / antimalware software issues (depends on AV etc) often fixed by EXCLUDING the relevant Arduino folders from the AV etc.

Running as ADMINISTRATOR also fixes quite a few issues.

Just thinking out loud here.