Arduino 101 receives power from USB but does not connect as a device

I have been working with this Arduino a couple of days and I was able to run some examples. However, overnight the board is not present as a device when I plug to the USB.
The IDE tries to fund it in COM8 but does not find it.
The green LED is on after plugging the board to the USB.
My OS is Windows 8.
This Arduino 101 is, practically, brand new. It has been used no more than 5 or 6 times just to train.

¿Is there any procedure to find out if the board is damaged and why?

By the way, I have tried to connect to a different laptop and no audible answer (gong) is issued by the Windows OS.

In both laptops the IDE menu option Ports is disabled however, a "select serial port" message is returned when trying id to retrieve information about the plugged board (it seems normal because also seems the OS did not recognize the board).

I just want to know if I have to throw the board to the dustbin or I can try to fit it in some way. The first option is quite awkward because the board is practically brand new.

I have also tried the loop-back test found in previous posts, but no audible answer nor new entries in the Device Manager of Windows appear.

Loop-Back Test Instructions...

  1. Disconnect power from the board

  2. Remove all connections and shields from the board

  3. Force the processor to remain in reset by connecting a jumper from RESET to GND

  4. Connect a jumper from the TX pin (Digital Pin 1) to the RX pin (Digital Pin 0)

  5. Connect the board to your computer. After a brief pause Windows will produce a device-insertion tone if sound is enabled. Linux may or may not produce a device-insertion tone; an entry is added to the system log.