Arduino 17 IDE opens, crashes on verify/compile

Hi everyone,

I have a brand new Deumilanove 328 that I can't use because the IDE hates me wont compile. The program opens, will open the example sketches, will save, but will not verify or compile a sketch. When these options are tried the program closes and I get multiple instances of avr-ar processes running in my task manager. There are no error codes anywhere that I can see.

Windows XP SP3, Java 6 u.17 freshly installed, Java folder in Arduino files renamed. Have triple(+) checked board settings and COM port. I've read all the threads I can find relating to this, but nobody seems to have had exactly the same issues, and I've tried all their solutions anyway.

I'm really hoping this is in fact unrelated to my Duemilanove, as it's brand new and appears to be functioning (power LED on, pin 13 led blinking), and the issue occurs whether it's connected or not.

Any help would be greatly appreciated, because I'm stumped and quite frustrated.

Thanks,
Adam

I'm really hoping this is in fact unrelated to my Duemilanove

Sure sounds like it.

These suggestions are shots in the dark...

  • Try again logged-in as an administrator
  • Ensure the AVR stuff is only installed once
  • Ensure the AVR stuff is the version you expect it to be
  • Try again with a different board selected
  • Ensure your login has full access to the Sketch directory (create, delete, read, write, modify)
  • Check that the environment variable TEMP refers to a valid location

Thanks for the quick response, Coding Badly. I tried what you suggested as far as what was in my ability but couldn't come up with a solution, but did ultimately find a solution;

It was certainly a software issue, though I'll probably never know where it originated. I wiped my computer back to factory condition and reinstalled the software, tested it, and everything is working fine without any adjustments necessary, which is a relief because I know now that it wasn't the Arduino software itself at fault. I can't imagine what caused it, which is too bad in case anyone else has this issue and isn't as prepared to wipe all their data. I hate to see a problem go unsolved.

Thanks again for the help,
Adam

I seem to be having the exact same problem, but with the Diecimila on Vista 32-bit. Arduino 17 crashes on verify/compile and leaves several instances of avr-ar.exe in the process list.

I have no idea what’s happening, but I opened an issue: http://code.google.com/p/arduino/issues/detail?id=179 for this. Please post if you have any more information.