Arduino 2560 as ISP for attiny45avrdude: Device signature = 0x000000

Hey, as said in the title, I've got a problem
while trying to upload a program to an attiny45.

SO here is My spechs :

-Ubuntu 18.04
-Arduino IDE 1.8.6
-Arduino MEGA 2560
-attiny 45
-uploading for a 1Mhz clock for the attiny45
-I'm using the famous board from https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json
-The full massage arrived when trying to upload this sketch :

void setup() {
}

void loop() {
}

here is the full error message (sorry it's in french):

and here is my pin mapping :

attiny45 to atmega2560


pin 1 || pin 10(reset)
pin 4 || ground
pin 5 (MOSI) || pin 51
pin 6 (MISO) || pin 50
pin 7 (SCK) || pin 52
pin 8 || to 5v

and a 10µF from reset to ground.

Tht's it. I hope I you got enough info to help me.

And sorry for my bad english.

The 10uF cap needs to be between the reset of the mega and ground - is that how you have it wired?

Hey, Drazzy, thanks for your help!! Yes that was what I did.

But the problem is resolved!

So I don't really know what arrived during this night to my board but, this morning, I got rid of the attiny45
and continued with an attiny2313 -> the compilation and the upload were a success so I finished the project with it
( the project is a to try RF communication between an attiny and an arduino). And then a few minutes ago I tried again to upload to the attiny45 to see what will go wrong and abracadabra... It worked.

============ CONCLUSION ============
So for people who have the same problem, I don't have any solutions, sorry :confused:
==============================================

Sounds like it was a loose wire.