Arduino 2560 Mega not working.

Hello everyone,
my name's Xia and I'm kind of new to the forum: I've been using an Arduino Mega2560 in a 3d printer, together with the RAMPS 1.4. Recently, I don't know how, the electronics seems to have messed up: Arduino won't be recognized by the computer while plugged via USB. All of this mess happened after a heatsink from a stepper driver (4 of them on the RAMPS in order to move motors) has fallen: I heard a little buzz, then the whole machine would slowly turn off itself, revealing random values on temperatures. I guess something in the Arduino has burnt out, not sure tho.
Any kind of help would be greatly appreciated.
Thanks in advance.

Xia Zhou

If needed I'll post photos of the electronics.

View My Video
Added a video showing how the LCD auto-turns off. Looks like something in the electronics overheating, but I don't know which part is damaged.

You should firstly measure the voltage on the supply rails, only turning on
the power for a short time to measure - if the voltages are low and some
component is overheating then it may have failed and overloaded the regulator.

If the voltage is absent, the regulator might be blown.

If all the voltages are OK, still check for overheating components - usually
an overheating component is beyond saving.

Dear MarkT,
thanks for your answer. Unfortunately, I'm not so expert about electronics: by "supply rails" you mean the PSU wires connected to the boards? If so they're connected on the RAMPS (12V/5V), which is installed on the Arduino 2560.
I apologize for not knowing very well how to behave, but I've never done such electronics works before.
Thanks

Edit: RAMPS is a RepRap shield for the Arduino itself, in order to move motors and heat up heaters for the 3d printer.

Hi, Suggest you remove the Mega completely from the printer, connect it by USB and check it.

I think you have a recent MEGA type that has a USB interface that is another small controller chip for USB interface. It is SQUARE and small and near the USB connector.

You might have:

  • Nothing Wrong when you run from USB and disconnected from everything else
  • Damaged the Mega processor :frowning:
  • OR, the USB Controller chip firmware became corrupted due to slowly-dying 5V supply

If the Mega is still not recognized, See “Repairing an Arduino Mega or Uno USB port” HERE:

Good Luck! And tell us here WhatHappened!.

Dear terryking228,
thanks for the answer given. I've disconnected ArduinoMega from RAMPS, plugged via USB, but still it doesn't get recognized, neither by Arduino IDE nor by the system itself.

I suppose the small controller chip for USB interface you're talking about is the one inside the orange rectangle, isn't it?
Moreover I've noticed that the Voltage Regulator (inside the red rectangle), heats up very quickly when board is plugged to RAMPS. Could that be the cause of this mess?
I'll be trying the guide you suggested as soon as I clearly figure out what is wrong on the board.

Thanks very much in advance for your help.

Hi XiaZ, and welcome to this world.

You have correctly identified the controller and the regulator.

You told us a heatsink dropped from one of the drivers on the RAMPS board.
Where did it land after the drop ?
Did it damage the Arduino board ?
Or The RAMPS board ?

If the controller heats up very quickly while the board is not connected to anything but a power supply and the USB connector, that raises suspicion of a short circuit on your board or inside the controller.
This can be caused by an other hardware fail on the RAMPS board.
But you stated it heats up when connected to your RAMPS board.
So that points to some failure on the shield .

The already given advices still stand:
Connect a multimeter (you need one) to the power supply, switch on the meter and then power up briefly, just long enough to do the measurement.

Dear MAS3,
thanks for your answer and your interest.
The heatsink dropped off the driver, I simply found it below the electronics, which were fit with bolts/nuts to a plastic frame attached on the 3d printer. Unfortunately, I've no idea which one of the 2 boards are damaged (or both, really hope not).
While RAMPS is fit on ArduinoMega 2560, it's kind of hard to me to measure the regulator or the controller, because of the very poor space available to measure, however I do have a multimeter to play with at the moment.
Any other advice will be greatly appreciated.
Thanks in advance for your help.

Edit: tried to plug a 5v into the Arduino Mega barrel power supply, measured the regulator on Pin 1 (red cable) and on Pin 2 (black cable), gave me result of -3.43, having the multimeter on scale 20 V. Still it doesn't get recognized by the Arduino IDE.

If you power the arduino through the barrel plug, the power supply voltage needs to be 7-12 volts, because it gets regulated to 5V and the regulator wastes at least 2V.

If one of the chips is broken, it is probably impossible to fix, unless you really are a rocket surgeon. Rocket scientist is not good enough skill for this, you really need the surgery competency as well.

But anyhow, if you think the voltage regulator is broken, you can ignore it and supply a good, regulated +5V to the Vin pin on the arduino.

And if you think the USB translator chip is broken, you can get a USB-serial translator board for about $3 and connect the usb to the pc and the serial wires to pins 0 and 1 on the mega which is the serial connection. This might work for connection to the pc so you can test it. It might depend on whether the Usb translator chip on the board is busted open-circuit or closed-circuit

I suppose the small controller chip for USB interface you're talking about is the one inside the orange rectangle, isn't it?

Yes, that is the USB interface controller.

The 6-pin connector just above it is what you would use to reprogram the USB Controller.

There is a good page on doing the reprogramming HERE:
This assumes you can get a little USBASP programmer. It MAY be able to do this with another Arduino as programmer, but I don't have a How-To for that. Anyone??

Dear michinyon,
thanks for your answer. Tried to plug a 7.5V into the Arduino barrel, can feel the regulator slightly heating, measured on 20V scale with multimeter on Pin 1 (red cable) and Pin 2 (black cable): -5.00 is the result.
However, the board still doesn’t get recognized by the system nor by the IDE.

Dear terryking228,
thanks for your answer. I’m glad I was able to find out what you were talking about. I haven’t looked for an USBASP yet, but sure I will do if it’s the only solution left not to throw away the board directly into the trash.

But anyhow, if you think the voltage regulator is broken, you can ignore it and supply a good, regulated +5V to the Vin pin on the arduino.

Perhaps you meant to say one can supply a regulated +5vdc to the shield 5V pin. Vin pin must be in the 7-12vdc range.

Did couple of tests this afternoon: while plugged with a 7.5V, Arduino works together with the LCD, supplying enough power to run it smoothly. USB still doesn't work, tho. Voltage Regulator heats up quiet a lot, I hope a fan will keep it stable.
So, I guess the only solution is that USB controller chip (Mega8U2) needs to be switched with an USBASP, am I right?
Then cut off the diode on RAMPS board (which feeds the Arduino) and simply external supply the Arduino board.

Voltage Regulator heats up quiet a lot

If this the case with nothing connected to the arduino, then there is probably a short somewhere on the board. Does the arduino power up when connected to the pc USB port? If there is/was a short on the board, the pc USB port may be damaged or needs to be reset (reboot pc).

Dear zoomkat,
thanks for the answer and your interest.
Arduino does power up when connected to the pc (stable light near ON + 2 blinks near L), still it doesn't get recognized by Arduino IDE (nor by the system itself).

When RAMPS + LCD shield is on Arduino Mega, if plugged via USB, the LCD displays faded texts, but I'm still able to control (move through the menu).

When RAMPS + LCD shield is on Arduino Mega, if plugged via USB, the LCD displays faded texts, but I'm still able to control (move through the menu).

That appears to be a low voltage condition. What is the voltage measured on the arduino 5v pin?

Hello everyone,
today I bought a brand new Arduino Mega 2560 Rev3, still the 3d printer's electronics don't work.

Reporting some tests:
Mega+RAMPS+LCD Shield via USB: faded text.
Mega+RAMPS+LCD Shield via PSU: LCD shows trash text.
Mega+RAMPS+LCD Shield via PSU (removed E stepper driver): LCD works for 5 sec, then switches to trash text again.
Mega+RAMPS+LCD Shield via PSU (removed E and X stepper drivers): LCD works fine.

Now, I assume something is wrong with the RAMPS board or the little stepper drivers themselves.
Could a couple of wounded drivers, short out the entire RAMPS board (making it not to work properly)?

@zoomkat: while plugged through barrel (9V), it measures 5V, which should be the correct voltage for the board. I do not dare to fry another Arduino, that's why I'd rather not connecting it together with RAMPS.

Sure.
That makes it quite likely that one of the drivers (the smallest boards) is defective, or anything connected to it.
So switch the boards and try to find the one(s) that is defective.
You might want to test each board by just plugging in that one board.
Plug a board that seems to be good into every socket so you can rule out the RAMPS board itself has some defect too.
These boards can be purchased separately and don't seem to be very expensive.

Make sure that you set the current limit correctly.
Don't just turn them all to the fully open side (i'm not sure whether that is clockwise or counterclockwise).

@MAS3
Thanks for you reply.
Bought couple of spare drivers, turned trimpots all the way down (CCW), but the board still seems to be messed up.
By testing the driver boards, I’ve noticed that with stepper drivers plugged into the RAMPS, the shield loses power.
What component of the RAMPS board is this loss of voltage related to?

Thanks in advance.

The drivers need 12 volts and 5 volts power.
The 5 volts are made out of the 12 volts.
Use your multimeter to see if 12 volts are present at all times.
If they drop a lot, the 5 volts can not correctly be produced anymore.
If it is stable, check the 5 volts power supply.

I'm not sure where you get this 12 and 5 volts from.
The schematics i found aren't clear about that.