Arduino-as-ISP Sketch: What's The Secret?

I load in the Arduino-as-ISP sketch onto an UNO, then add the cap, then hook it to a Leonardo. I line up the tools as needed, pull up the blink sketch, and try to upload. The 1.5.8 software reports it uploaded! But wait! The Leonardo refuses to blink!

So, I try to upload it to a Duemilanove (and line up the tools for it) with the UNO as programmer and.... (drumroll) AVR Dude chokes after 10 tries with a not in sync error.

I have the 1.5.8 software running on an Xubuntu 14.04 64 bit box.

Is the sketch to make the UNO into the ISP flawed and I'm not told a secret to fix it or what?

No, I've used it recently to program attinys without any problem (though I finally got myself a usbasp this week so won't need to do that any longer).

An ebay/aliexpress usbasp is only like USD4 and pretty much zero hassle.

I originally had the sketch on a Duemilanove and like the UNO with the sketch it never worked. I tried to do an ATTiny months ago to no avail. The Duemilanove and UNO I tried to use as the programmer are both genuine Arduinos and I used the cap on both.

Why I'm trying this is because I cannot get a Leonardo to work on my Linux box because of its screwball bootloader that needs to be bypassed.

and try to upload

More specific, please. Did you identify your programmer under the Tools menu? Did you attempt to upload using the GUI "icon" or file menu 'upload using programmer'? ... The latter option being correct.

I went to the Tools and selected the Arduino as ISP option when I tried it for the Programmer choice. With the dreaded Leonardo. For the Tools doard option, I of course selected the Leonardo and selected the port with the programmer on it. In my case it's /dev/ttyACM2 as I'm using the ACM0 and ACM1 ports for Christmas lights with relay shields. Those two UNOs have anti-reset caps like an Arduino as ISP has. I'm running a shell script to do the lights.

With the UNO as the programmer to program the Leonardo, the 1.5.8 software said the upload worked but it still didn't.

Trying the "upload using programmer" option in the "File" menu, instead of an erroneous success, I get this fail message:

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00 avrdude: stk500_recv(): programmer is not responding

It repeats for all 10 times and it's a fail of course.

Try using Nick Gammon's bootload installer sketch instead.

I did succeed at uploading a sketch to the Leonardo. I posted the posting with "SUCCESS!" in the title with how I finally did it. I used my UNO-as-ISP hooked to the ICSP header on the Leonardo.

Note that the first time around, I did have to hit the reset button on the Leonardo but subsequent tries worked just fine without doing so. I probably nuked the hosed bootloader I can't use anyways so it's no loss.