Arduino Bootloaders for Atmega164, Atmega324, Atmega644 and Atmega1284 ?

Are there arduino bootloaders for atmega164, atmega324, atmega644 and atmega1284 ?

I know there is a sanguino bootloader for the atmega644 !

Yep for some of those Mark has done some good work on alot of chips - He should be able to assist you if you need something.

http://avr-developers.com/cputable.html

http://avr-developers.com/corefiles/index.html

Hello, I have sucessfully flashed an atmega 328 with the bootloader. Now I have an other problm. I would like to use a 644-20PU (44 pin). I read about sanguino and the 644 and 644p bootloader. Can somebody tell me if the bootlader for these 40 pin controllers will work with the 44 pin controller. I know, they have different pinout. Thanks a lot! Robert

I have a Atmega644P-20PU it has 40 pins, the Atmega644PA-20PU has 40 pins too !

Hello,

I am sorry, I just saw it is a 644-20AU! Is there a bootloader available or can I use the one vor the 40 pin version?

Thanks Robert

I don't know.

But you can try it. Try to transfer the bootloader to your Atmega644, then the blinkwithoutdelay Sketch !

ok, I will try it and reply as soon as I know how it does! thanks and a good evening! Robert

You can then connect a led, with a resistor, to each digital out pin.

Then you can check them with a sketch !

This show you if it react like the other atmega644 !

One led after the other !

good idea, I will make it this way. Robert

Hello, I've been trying for hours to get the 644-20AU running with the sanguino bootloader. I used a Duemilanove board and this method: http://www.geocities.co.jp/arduino_diecimila/bootloader/index_en.html I had no problems flashing Atmega 328 on the Duemilanove but encountered problems with the 644:

First I connected the 4 control pins of the FT232RL with ICSP Pins of the 644 as well as 5V supply. Reading and setting fuses worked fine. I set

low bit FF high bit DC and extended bit FD

Erasing and reading flash also worked without trouble. After writing the ATmegaBOOT_644 and ATmegaBOOT_644P I got an rc -1 error although avrdude wrote the code and an error message of different files after verifying. I read it again and the hex file was not empty.

After that I conected RX/TX and 5V from the duemilanove to the 644 and tried to flash a sketch via the FTDI chip of the board but It did not work (avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51) Sanguino software was of course installed and sanguino selected.

Can anyone give me a hint ?

Thanks Robert

I had in the past a equal problem: http://arduino.cc/forum/index.php/topic,22205.msg166852.html#msg166852

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

When burning the bootloader then it's miso and mosi who are used for the transfer.

The sketch are transfered with rx and tx.

Try it with different speed settings in the serial monitor ! From the lowest to the fastest !

I tried to transfer a sketch via Rx/Tx but no way.

Is there an influence on the speed rate of the sketch-transmission when changing the serial monitor settings?

not in sync: resp=0x00

This message had give me the idea that the arduino ide and the atmega644 talks in different speed.

not in sync = not in syncronisation

ok, but what can I do then? I assume, that changing baud rate in serial monitor does not affect baud rate during sketch upload.

I have ordered a USB to TTL cable, as suggested for sanguino, yesterday. Do you know, if there are differences between this cable and the FTDI chip on a duemilanove?

Read this: http://sanguino.cc/breadboardsanguino

under serial !

You can use a arduino without a atmega on it to transfer the sketch to the atmega644.

You must connect rx from the arduino board with the tx from the atmega644. The tx from arduino to atmega644 rx.

Then select sanguino W/atmega644p under boards before you try to transfer the sketch !

oh, good, thanks for that! I'm going to try this out this evening and reply with the results tomorrow! Robert

So, I tried to flash a sketch via arduino board without atmega and a TXRX connection to the powered 644. Still no chance to transfer, 'not in sync'. I fear, the bootlaoder for the 644 and 644p does not work with a 20AU chip. Has anybody further ideas? Robert

What crystal are you using?