Arduino BT ATmega328 / BT-V06

Hab mal eine Frage bin seit zwei Tagen Besitzer eines Arduino BT und eines Arduino Mega ADK.

Ich habe auch schon ein paar sektchs ausprobiert und die laufen alle auf beiden Borads.

Nun zu meiner Frage ich würde gerne das Arduino BT ATmega328 / BT-V06 auch über das BT on Board auslesen und steuern aber habe keine Ahnung wie das gehen soll! Habe für BT Modulen auch sketchs gefunden aber die sind alle extern mit Shields mit dem UNO. Habe dann versucht mit den rum zu spielen aber das geht nicht das ich mit der Blue Control V2.0 in Android Market ne LED an und aus machen kann.

Hat jemand vielleicht nen Tip parat oder nen Link wo sowas als Beispiel erklärt wird. Für das Arduino BT Wo das Modul schon drauf ist kann ja darüber auch sketchs laden auf das Board!!

Hatte auch gesehen in einem Youtube Video das man an das Mega ADK am USB Anschluss auch nen Bluetooth Dongel anschließen kann aber wie geht das? Hat da vielleicht jemand nen Link oder einen Hinweis? Habe auch auf der Developer Androidseite Wegen dem ADK geschaut aber er gibt mir Fehler aus.

IDE: Arduino 1.0 Version Arduino Mega ADK ist die neuste Version.

Das kommt raus wenn ich verify klicke:

demokit.cpp:4:22: error: Max3421e.h: No such file or directory demokit.cpp:5:17: error: Usb.h: No such file or directory demokit.cpp:6:30: error: AndroidAccessory.h: No such file or directory demokit.pde:-1: error: 'AndroidAccessory' does not name a type demokit.cpp: In function 'void init_buttons()': demokit.pde:-1: error: 'A8' was not declared in this scope demokit.pde:-1: error: 'A9' was not declared in this scope demokit.cpp: In function 'void setup()': demokit.pde:-1: error: 'A8' was not declared in this scope demokit.pde:-1: error: 'A9' was not declared in this scope demokit.pde:-1: error: 'acc' was not declared in this scope demokit.cpp: In function 'void loop()': demokit.pde:-1: error: 'acc' was not declared in this scope demokit.pde:-1: error: 'A8' was not declared in this scope demokit.pde:-1: error: 'A9' was not declared in this scope demokit.cpp: In function 'void init_joystick(int)': demokit.pde:-1: error: 'A9' was not declared in this scope demokit.pde:-1: error: 'A10' was not declared in this scope demokit.pde:-1: error: 'A11' was not declared in this scope demokit.cpp: In function 'char joystick_interrupt()': demokit.pde:-1: error: 'A10' was not declared in this scope demokit.cpp: In function 'char read_joy_reg(char)': demokit.pde:-1: error: 'class TwoWire' has no member named 'send'

As of Arduino 1.0, the Wire.send() function was renamed to Wire.write() for consistency with other libraries.

demokit.pde:-1: error: 'class TwoWire' has no member named 'receive'

As of Arduino 1.0, the Wire.receive() function was renamed to Wire.read() for consistency with other libraries.

demokit.cpp: In function 'void write_joy_reg(char, char)': demokit.pde:-1: error: 'class TwoWire' has no member named 'send'

As of Arduino 1.0, the Wire.send() function was renamed to Wire.write() for consistency with other libraries.

demokit.pde:-1: error: 'class TwoWire' has no member named 'send'

As of Arduino 1.0, the Wire.send() function was renamed to Wire.write() for consistency with other libraries.

MFG Neomatrix433

Dir fehlen folgende Bibiotheken: Max3421e.h , Usb.h , AndroidAccessory.h Du muß diese in die Directory arduinoxx/libraries kopieren. Achtung: jede Bibiothek muß in einem directory mit ihrem namen sein zB: arduinoxx/libraries/Max3421e.h/Max3421e.h [RICHTIGSTELLUNG]arduinoxx/libraries/Max3421e/Max3421e.h[/RICHTIGSTELLUNG] Grüße Uwe

Ne alle Bibliotheken da!

Auf der Androidseite steht:
On Windows:
Copy the firmware/arduino_libs/AndroidAccessory and firmware/arduino_libs/USB_Host_Shield directories (the complete directories, not just the files within) to the <arduino_installation_root>/libraries/ directory.
Create a CapSense directory in the <arduino_installation_root>/libraries/ directory
Copy CapSense.cpp and CapSense.h from the unzipped CapSense download to the CapSense directory.

Alle Verzeichnisse sind vorhanden und da sind auch die Bibliotheken drin. Wo die Headerdateien drin sind sind auch die *.cpp Datein dirn also alles da
C:\Users\Benutzername\Desktop\arduino-1.0\libraries\firmware\arduino_libs\AndroidAccessory\AndroidAccessory.h

C:\Users\Benutzername\Desktop\arduino-1.0\libraries\firmware\arduino_libs\USB_Host_Shield\Max3421e.h

C:\Users\Benutzername\Desktop\arduino-1.0\libraries\CapSense\CapSense.h

Werde nachher wenn ich wieder Zeit habe weiter Probieren.

Zu meiner Frage mit dem Bluetooth nen Lösungs vielleicht?

C:\Users\Benutzername\Desktop\arduino-1.0\libraries\firmware\arduino_libs\AndroidAccessory\AndroidAccessory.h muß nach: C:\Users\Benutzername\Desktop\arduino-1.0\libraries\AndroidAccessory\AndroidAccessory.h usw. Grüße Uwe

Es lag dann doch nicht an den Datein. Sondern an der Arduino IDE hatte die 1.0 mit der gab es dann die Fehler! Habe mir dann die 0023 Version runter geladen mit der konnte ich ohne Probleme uploaden auf das Mega ADK Board.

Jetzt habe ich aber das Problem das ich die DemoKit.apk auf einem XooM und auf dem Desire installiert habe und es steht immer nur Pleace connect a DemoKit board.

Wenn ich dann per USB das Board anschließe passiert nichts in der App!

Woran kann das liegen? Ist der USB defekt und das bei einem niegelnagelneuen Board????