ARDUINO BT trouble


i had an arduino BT board running in an installation for 2 weeks without problems.
then the gallery called me that something is wrong.

now i have an arduino BT which behaves the following:
the led on pin 13 is blinking 3 times every approx 10 seconds.
this is the behaviour when there is no programm on the chip - right ?

bluetooth connection works:
it looks that i am able to upload software as the IDE reports:

Atmel AVR ATmega168 is found.
Uploading: flash
Firmware Version: 1.15
Firmware Version: 1.15

but the program i uploaded does not start. the board continues with its
behaviour as there would be no program stored.

the code i m uploading for test is the led blink programm which comes with the ide
i have another board where everything works fine.

anybody an idea ?
the bootloader on the chip seems to work as the led blinks 3times and the ide
is able to communicate.
what does it actullay mean when the ide reports that it found the chip
and uploaded to the flash?
is there another way to diagnose what might be wrong with the board?




the blink means the bootlader is working... if it blinks in a cycle of three blinks...pause..three blinks.. this means either there is no program to run or that it is sensing that it is about to be programmed, and then times out waiting to be programmed. Do you have anything on the RX pin of the Atmega168, other than the BlueGiga BT chip?


no nothing on rxtx - its completely bare



if you disconnect the peripherals you're using/driving (leds etc), does it work properly? My next guess is that you may be overtaxing the power supply, forcing a reset. In any case, the way to troubleshoot this is to go back to basics.. see if you can make the BT module perform correctly on its own without anything connected.


hello daniel,

everything i described is without peripherals. i m powering the bt arduino with 5V from usb.
before that in my installation the bt arduino was powered by a 7805 and as i mentioned it was running
without a problem for 2 weeks until it was not working anymore is it seems not starting
the software.

could it be that the bootloader which is on the chip got "damaged" ?
which leads me to the next question - can i reinstall the bootloader
on the bt arduino by myself via the bt connection?



ps: i ll try with less power just to see if there is any change in behaviour


yes you can reinstall the bootloader... One thing with the BT is that the Bluegiga BT module is used for sending data serially to the Atmega, AND for reprogramming the functions of the Bluegiga itself. If you had something strange in your code you may have inadvertently told the Bluegiga to do something new, or change its function. Not likely, but it is a place to start.

There are a couple tutorials in the Playground on how to reprogram the bootloader and the Bluegiga. To burn a new bootloader you will need a programmer. To just reset the Bluegiga operating parameters, you can just use the Bluetooth connection. Look near the top of this page.


hello erich

i don't know if it helps, but today after installing arduino on my desktop i faced exactly the some situation you described. i tried a lot of things before finding the solution, btw a very simple one? check in the tools-microcontroller menu if the atmega168 is selected instead of atmega8


hello pedro,

thank you for your suggestion but that is not the case.
i have another BT board which just works perfect.
i really believe that there is something wrong with the board itself.




I had 35 of the BT boards in the spring for a course I was teaching... For the most part they worked really well. The hardware on them was remarkably robust. The mojority of probelms that students had with the boards traced back to one of the following:

  • bluetooth driver problems on windows (very frequent);
  • conflict between ATMEAG168 Arduino code and BlueGiga module(e.g. not using the default speed of 115200 baud) (rare);
  • student had connected something to pin 7, which is the reset pin for the BlueGiga;
  • bootloader was corrupted somehow (only happened once or twice, not really sure how, may have been due to my reprogramming the bootloaders to give modules a new name)

The only hardware problem we ever had was with the soldering of the power pins on the power connector, as we had the first production run of the BT modules, done with RoHS solder. This made a couple modules act intermittently strange, but was easily fixed with a bit of leaded solder.

Can you give us more information to help you troubleshoot it? what about the code you're using and some pictures of the actual module and how it's connected?

Hope this helps,


bootloader was corrupted somehow (only happened once or twice, not really sure how, may have been due to my reprogramming the bootloaders to give modules a new name)

I am experiencing the same problem with my arduino bt. I went to reprogram a name and key on the bluegiga module. A few minutes later I unplugged the power, then a few seconds later back in.

Now pin 7 seems to be strobing on/off. It sharply rises to high, then slowly drops to ground, and repeats a bunch of times a second. I cannot see the bluetooth module from my PC unless I tie down the MCU's reset line.

Problem solved by uploading program right after plugging in. This had me freaked!