Arduino BT upload problem

I have an Arduino BT V06 that I could connect to my Mandriva 2010 linux laptop: "rfcomm connect" is working, /dev/rfcomm0 virtual serial port is created, "hcitool con" shows the connection and "hcidump" displays my upload attempts. However when I try to upload the BlinkWithoutDelay example I got the following error message (upload.verbose set to true in .arduino/preferences.txt):

/usr/local/arduino-0021/hardware/tools/avrdude -C/usr/local/arduino-0021/hardware/tools/avrdude.conf -v -v -v -v -patmega168 -cstk500v1 -P/dev/rfcomm0 -b19200 -D -Uflash:w:/tmp/build8547029001705996442.tmp/BlinkWithoutDelay.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 22 2007 at 13:15:12 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

System wide configuration file is "/usr/local/arduino-0021/hardware/tools/avrdude.conf" User configuration file is "/root/.avrduderc" User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/rfcomm0 Using Programmer : stk500v1 Overriding Baud Rate : 19200 avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: ser_recv(): programmer is not responding avrdude: stk500_recv(): programmer is not responding avrdude: Send: Q [51] [20] avrdude: ser_recv(): programmer is not responding avrdude: stk500_recv(): programmer is not responding

I was struggling for several hours to solve the problem. I am using Arduino-0021 but I have also tried it in 0018 and 0015 without luck. I have also tried with board type BT Atmega 168 and BT Atmega 328. My Arduino Duemilanove works fine with the same computer, Arduino 0021, and settings. I have seen several question with the same topic http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1290646119/1 or http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1247005623. They mention differing error messages and anyway I cannot see how can I press the reset button on the Arduino during the upload when I have to type the PIN in a different window.

What could be the solution to the problem?

What I could imagine is to buy a BlueGiga WT11 chip extension to my Duemilanove and do the upload via USB. But how could I be sure that the connection for the communication will work? Moreover I still would like to use the not-so-cheap Arduino BT board.

Hi,

maybe we have the same problem - I could test the function of my BT Arduino with Windows 7.... The reason is the wrong baud-rate. You are sending with 19200 baud, but you should with 115200... . Under Windows you can change the settings in a file named boards.txt in the section of your BT-board, but I don't know where you can find these settings on linux, nor on my mac OS. Maybe I could help you ... Regards, LPD :)

@LPD: Thank you for the answer. I have tried it with 115200 baud but it still did not work.

Hi rics,

... I'm sorry to tell you, that I was also not able to start my board with the new baud rate. The problem is bigger - It might be a design-bug in all boards: when you press the reset-button (what you should do before uploading) you also reset the BT-module - this, of course, interrupts the communication..... (Pls. read also the posts http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1260439671)

I think, we're in trouble my friend :-/

I will try to find a solution for my board - if I find some, I'll tell you...

Regards, LPD