Arduino BT Uploading Prob (newb)


New enough to arduino, had no probs with the diecimila but I recently purchased the BT and haven't been able to upload to it from arduino.exe. I'm using vista. I've heard people say that sometimes com ports over 10 aren't accepted so I've changed to com2 and baud 115200 (i've tried 9600 too). I can connect to the device from bluesoleil (via a dongle) and even when I run the arduino sketch it latches on to the board (i.e. icon changes to green) but I always get the error:

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

In the troubleshooting page on arduino website it specifies that programs like bluesoleil should be closed when uploading as they can take over the comport but I'm assuming that this does not apply with the BT version as there could be no connection if I closed bluesoleil.

I've tried running many different sketches, all will compile but not upload. Could it be a bootloader prob (I'm nearly sure BT comes with the bootloader on board?)

Any suggestions much appreciated.

I believe that vista a built in bluetooth connection wizard, try using that instead or download another program to connect the bluetooth.

My new laptop with Vista, I always seem to get that sync error as well, but the upload actually does get completed.

The trick with the BT board is to find the right sequnces of pressing the reset button the on board at almost the same time as starting the sketch upload. There is a pretty narrow window where the boot loader will grab and start the upload process.

Start with the simple digital "blink" example so you can easily see the upload has completed since the built in led will start flashing when that sketch runs.

(port 40 works fine here)

Yes, I get this with Vista too.

In fact, I'd despaired of ever getting my BT working at all - spent hours on it with my iMac and my old XP laptop, to no avail.

I'd pretty much given up on it, but decided to try it with my new Sony Vaio TZ laptop, running Vista. It still gave me the sync errors (just trying to load the blink sketch) and I was about to give up on it... when I noticed the LED on the BT was blinking!

I tried uploading a few more sketches and although the IDE keeps giving me the sync error, it does actually appear to be uploading sketches fine. Hurray!!!

Hi! I am also having this problem. I am also connecting to my Arduino BT with BlueSoleil. When I click the reset button on my Arduino BT the connection between the Arduino BT and my computer dies. The dotted line in BlueSoleil disappears. Can I program Arduino BT when the connection is lost? Or is it lost?