Arduino can not compile =(

I got a problem in compiling. I am using Arduino 1.0, and it works OK so far in my Laptop and PC. But when I use my netbook, the arduino cannot compile every example project provided there... Three of them (PC,Laptop,and notebook use Windows XP) When I compile it, it appears issue : Build folder disappeared or could not be written

What's wrong here? Anyone please help me?

Vielen Dank (Thank you so much)

Using Explorer navigate to the %TEMP% directory. Are you able to create sub-directories? Are you able to create files?

Can you tell me step by step? Yes sure I can create file and sub-directory, it's my personal stuffs.

Vielen Danke

• Open Explorer
• Enter %TEMP% into the address bar
• Press the Enter key
• Click File then New then Folder
• Press the Enter key
• Press the Enter key
• Press the Enter key
• Click File then New then Text Document
• Press the Enter key
• Press the Enter key
• Type “this is a test”
• Press the Alt then F4 keys
• Press the Enter key

Any problems?

Wooow, thank you so detail instructions.

no problem, the file is finally created.

Hmm, what's the problem then? :drooling_face:

Turn on verbose output for compile. Post the output. Please use
</mark> <mark>[code]</mark> <mark>

</mark> <mark>[/code]</mark> <mark>
tags.

java.io.FileNotFoundException: H:\arduino-1.0\build_folder\Blink.cpp (The system cannot find the path specified)
	at java.io.FileOutputStream.open(Native Method)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
	at processing.app.preproc.PdePreprocessor.writePrefix(PdePreprocessor.java:139)
	at processing.app.Sketch.preprocess(Sketch.java:1330)
	at processing.app.Sketch.preprocess(Sketch.java:1282)
	at processing.app.Sketch.build(Sketch.java:1564)
	at processing.app.Sketch.build(Sketch.java:1546)
	at processing.app.Editor$DefaultRunHandler.run(Editor.java:1845)
	at java.lang.Thread.run(Thread.java:619)
processing.app.debug.RunnerException: Build folder disappeared or could not be written
	at processing.app.Sketch.preprocess(Sketch.java:1337)
	at processing.app.Sketch.preprocess(Sketch.java:1282)
	at processing.app.Sketch.build(Sketch.java:1564)
	at processing.app.Sketch.build(Sketch.java:1546)
	at processing.app.Editor$DefaultRunHandler.run(Editor.java:1845)
	at java.lang.Thread.run(Thread.java:619)

is it what you meant?

Anw I compile Blink from the example.

is it what you meant?

Yes.

There should not be a folder named “build_folder”…

H:\arduino-1.0<mark>build_folder\

…in the Arduino directory. I suggest re-installing.

What do you mean re-installing? Re-installing my windows xp or my arduino?

I had tried to re-installing arduino1.0 by deleting the arduino 1.0 folder then re-extract rar file from arduino.cc…but it shows same problems.

creativen: What do you mean re-installing? Re-installing my windows xp

No.

or my arduino?

Yes, the Arduino software.

I had tried to re-installing arduino1.0 by deleting the arduino 1.0 folder then re-extract rar file from arduino.cc...but it shows same problems.

rar file? Did you download the wrong thing?

I downloaded this…
http://arduino.googlecode.com/files/arduino-1.0-windows.zip

I thought it is not wrong, since it is working in my PC and notebook, but not working in my netbook.
what do you think?

That's the correct download. I assume by "rar file" you meant "zip file".

There is no "build_folder" in the Arduino zip file. Is that something you created?

I also am having the same problem. I created the files perfectly. I do not want to re-install. It has been working for months fine. Just today it started acting up. Any suggestions?

yosler: I also am having the same problem.

You have a folder named "build_folder" mysteriously showing up in your Arduino directory?

Problem fixed! It's working fine now. I restarted the program and nothing is wrong. If this ever happens to anyone, they should just restart it and see if that fixed it. :)

Maybe the file is there.

Thank you for the follow-up.

I found the file. First the build folder. And the cpp file is in the build folder!! :)